Complete Lab Manual Computer Networks1
Complete Lab Manual Computer Networks1
Complete Lab Manual Computer Networks1
LAB MANUAL
COMPUTER NETWORKS
Part A:Background/Preparation
This lab assumes that you are using Windows NT/2000/XP. This is nondestructive lab that you can
perform on any host without changing the system configuration.
Ideally, you perform this lab in a LAN environment that connects to the Internet. You can use a single
remote connection via a dial up modem or DSL. You will need the IP address information which the
instructor should provide.
Introduction to IP addressing
Each Network Interface Card (NIC or Network card) present in a PC is assigned one Network address
called as IP address [or Network address]. This IP address is assigned by the administrator of the
network. No two PCs can have the same IP address.
There is a burned-in address on the NIC called as Physical Address [or MAC address or Hardware
address]. The MAC address of a network card indicates the vendor of that card and a unique serial
number.
Rules for IP 4 Addressing
1. Format of IP address IPv4 is made up of four parts, in the pattern as w.x.y.z. Each part has 8
binary bits and the values in decimal can range from 0 to 255.
2. IP address classes
IP addresses are divided into different classes. These classes determine the maximum number of hosts
per network ID. Only three classes are actually used for network connectivity. The following table lists all
of the address class.
In this exercise, you will determine the correct class for a given IP address.
2. Which address class (es) will allow you to have more than 1000 hosts per network?
3. Which address (es) will allow only 254 hosts per network?
4. Identify invalid IP address:
Circle the portion of the IP address that would be invalid if it were assigned to a host, and
then explain why it is invalid.
a) 131.107.256.80
b) 222.222.255.222
c) 231.200.1.1
d) 126.1.0.0
e) 0.127.4.100
f) 190.7.2.0
g) 127.1.1.1
h) 198.121.254.255
i) 255.255.255.255
Network Configuration
Establish and verify connectivity to the Internet. This step ensures the computer has an IP address.
c. The screen shows the IP address, subnet mask and the default gateway. The IP address and the
default gateway should be in the same network or subnet; otherwise this host wouldn’t be able
to communicate outside the network.
Step 3. Record the following TCP/IP information for this computer.
a. IP address:_______________________________________________
b. Subnet mask:_____________________________________________
c. Default gateway:__________________________________________
Step 4. Compare this computer’s TCP/IP configuration to that of others on the LAN. If this computer is
on a LAN, compare the information of several machines (Hosts).
2.____________________________________________________________
3.____________________________________________________________
a. To see more information, type ipconfig/all and press Enter key. The figure shows the detailed IP
configuration of this computer on the screen.
b. You should see the following information: the host name (computer name), the Physical address
of this machine, IP address, subnet Mask, Default Gateway and DNS Servers.
c. In the LAN, compare your result with a few nearby computers. What similarities do you see in
the physical (MAC) address?
________________________________________________________________
Sept 1. Establish and verify connectivity to the Internet. This step ensures that the computer has an IP
address.
Step 2. Open the Command prompt(MS-DOS). Ping the IP address of another computer.
a. In the window, type ping, a space, and the IP address of a computer recorded in the previous
lab.
Ping uses the Internet Control Message Protocol(ICMP) echo-request and echo-reply feature to test
physical connectivity. Because ping reports on four attempts, it gives an indication the reliability of
the connection. Look over the result and verify that the ping was successful. Was the ping
successful? If not, report to the instructor.
b. Ask the IP address of the nearby computers and ping. Note the result.
______________________________________________________________
c. Ping the IP address of Default gateway and DNS servers. Was the result successful?
______________________________________________________
d. Ping the computer’s loopback IP address. Type the following command:
ping 127.0.0.1
e. The address 127.0.0.1 is reserved for loopback testing. If the ping is successful, then TCP/IP is
properly installed and functioning on this computer.
f. Was the ping successful for e.__________________________________________
g. Ping the hostname of the computer that you recorded in lab 1.1.
Step 3. Trace the route to the Umm-alqura university website: type tracert www.uqu.edu.sa and
press Enter key.
The result shows the complete route to the site and the number of hops in path.
Trace a local host name or IP address in your local area network (LAN).
Background/Preparation
This lab aim to construct straight through cable, used to connect computer to the Switch/Hub. It is used
to connect dissimilar devices. While cross cable is used to connect to computers directly. It is also used
when you connect to hubs/Switches with a normal port on both hubs/Switches. (In other words, the
cross cable is used relatively in a rare case.). It is used to connect similar devices.
Equipments/Tools: CAT 5 network cable, RJ-45 Connectors, Crimping tool, Cable tester.
Procedure
The wire has two sides. Let one side is Side A and the other side is Side B. Do the following steps with
Side A of the wire.
Step 1. Remove the plastic cover from the cable up to two inches. You will see 4 twisted pairs (total 8
wires). In each twisted pair one wire will be colored and the other will be white. For example one will be
Green and the other will be White having Green marks. The latter is called Green-White. Similarly there
will be Brown wire twisted with Brown-White, Blue wire twister with Blue-White, Orange twisted with
Orange-White.
Step 2. Untwist the wires and make them smooth(don’t remove the plastic covers from the metal
wires).
Step 3. Arrange the wires in the order: Orange-White, Orange, Green-White, Blue, Blue-White, Green,
Brown-White, Brown.
Step 4. Cut the wires in straight fashion and insert in the RJ-45 Jack.
Equipments/Tools: CAT 5 network cable, RJ-45 Connectors, Crimping tool, Cable tester.
Procedure
Side A
Repeat Steps 1 to 5 for side A similar to the process for straight through cable.
Side B
Arrange the wires as: green-white, green, orange-white, blue, blue-white, orange, brown-white, brown.
And punch it properly.
Configuration table
Lab n o 3
Building a Local Area Network
Theory
Repeater: With many networking terms, the name is indeed the recipe, and that's very true of a
repeater. A repeater's job is to repeat an electrical signal, the form that our data has taken to be sent
across a cable. Remember, "it's all ones and zeroes!”
The repeater takes an incoming signal and then generates a new, clean copy of that exact signal. This
prevented maximum cable lengths from stopping transmissions, and also helped to ward off attenuation
- the gradual weakening of an electric signal as it travels.
Hub: A hub is basically the same as a repeater, but the hub will have more ports. That's the only
difference between the two. (Some hubs have greater capabilities than others, but a "basic" hub is
simply a multiport repeater.)
Neither hubs nor repeaters have anything to do with the Data Link layer of the OSI model, nor do they
perform any switching at all. Hubs and repeaters are strictly Physical layer devices, and that's where the
trouble comes in. There are two major problems with hub
1. Only one PC at a time can send data so having one big collision domain. (Data sent by host can
collide with another host) to prevent this host on shared network uses CSMA/CD.
1. With hubs, we've got one big collision domain consisting of all connected hosts. When hosts are
connected to their own switch ports, they each have their own individual collision domain.
2. Hubs only allow one device to transmit at a time, resulting in shared bandwidth. Switches allow
hosts to transmit simultaneously.
3. When one host connected to a hub sends a broadcast, every other host receives that broadcast
and there's nothing we can do about it. When a host connected to a switch sends a broadcast,
every other host receives it by default - but there is something we can do about that, as you'll
see in the VLAN section of this course
How Switch works: Cisco Switch will do one of the three things with an incoming frame
1. Forward it
2. Flood it
3. Filter it
To make this decision, the switch uses its MAC Address table to check if there's an entry for the
destination MAC address - but first, the switch will actually check to see if there's an entry for the
source MAC address of the frame, because it's that source MAC that the switch will use to actually
build the table in the first place. How switch process frames shown below.
Flooding is performed when the switch has no entry for the frame's destination MAC address. When a
frame is flooded, it is sent out every single port on the switch except the one it came in on. Unknown
unicast frames are always flooded.
Forwarding is performed when the switch does have an entry for the frame's destination MAC address.
Forwarding a frame means the frame is being sent out only one port on the switch.
Filtering is performed when the switch has an entry for both the source and destination MAC address,
and the MAC table indicates that both addresses are found off the same port.
In this lab you will learn how to connect two computers directly to each other. This is the simplest
network you can imagine. The network having two directly computers connected is called peer to peer
network. Later on you will learn that such a simple network is not “according to the definition of
network.”
Equipment/Tools
Two computers having Windows XP/2000 and LAN Cards installed, one Cross-Over cable with
appropriate length.
Procedure
Step 1.
Identify the proper Ethernet cable and connect the two PC’s. Make sure that you are using the
crossover cable constructed in the previous lab. Turn off both the computers. Attach one end of the
cable in the Network Interface Card (NIC or LAN card) of one computer and the other end in the NIC of
the other computer.
Step 2.
Plug in and turn on the computers. To verify the computer connections, ensure that the link lights on
both NICs are lit.
Step 3.
Be sure to record the existing IP settings of both the computers, so that you can restore them ate end of
the lab. The IP setting information includes IP address, subnet mask, default gateway and the DNS server
information.
Step 4.
Perform on both computers. Click Start>Control Panel> Network Connection. Select the Local Area
Network Connection and click Change Settings of This Connection on the left side window. You will see
a figure showing the properties related to this connection.
Step 5.
Select Internet Protocol(TCP/IP) from the list and click the properties button. You will see a figure as
shown in the following figure.
Step 6.
Set the IP address information for each of the PC. This information will be provided to you by the
instructor.
Step 7.
Verify that the two computers can communicate. Use ping commands.
Step 8.
Restore the actual settings of both the computers you have recorded at the start of the lab.
You can share files, folders, printers and dialup network connection among these two computers.
In this lab you will learn how to connect two or more than two computers in a Local Area Network (LAN)
environment. The computers will be connected to one another via a central controller called switch (you
can use a hub instead. Ask your instructor for the difference). The topology will be star.
Equipment/Tools
Three or more computers having Windows XP/2000 and LAN Cards installed, Layer 2 Switch, Straight-
Through cables equal to the number of computers you want to connect with appropriate length.
Procedure
Identify the proper Ethernet cable and connect the two PC’s. Make sure that you are using the
crossover cable constructed in the previous lab. Turn off both the computers. Attach one end of the
cable in the Network Interface Card (NIC or LAN card) of one computer and the other end in the NIC of
the other computer.
Steps
Verify the connections to all the systems using the ping command.
If you have a home network and are running Windows 7 and have XP on other PC(s) you might want to
share files between them. Today we will look at the steps to share files and hardware devices like a
printer.
Sharing folders between two Windows 7 machines with the new HomeGroup feature is an easy
process, but the HomeGroup feature is not compatible with Vista or XP. For this tutorial we are
using Windows 7 x64 RC1 and XP Professional SP3 connected through a basic Linksys home
wireless router.
First make sure both machines are members of the same Workgroup which by default is named
Workgroup.
On the Windows 7 machine go into Control Panel \ All Control Panel Items \ Network and
Sharing Center then click on Change advanced sharing settings
You will want to verify the following settings under Advanced Sharing Settings for the Home or
Work and Public profile.
If you want any user to have access the public shares turn off password protection. This is
located in Advanced Sharing Settings toward the bottom of the list.
If you want to keep it enabled make sure there is a log in account for the other XP machines and
they have a password.
Now if you go into Network in Windows 7 you should see your XP machine and the Windows 7
as well which in this case is Mysticgeek-PC.
To share the printer on the Windows 7 machine go into Devices and Printers from the Start
menu and double click on the printer icon.
Next double click on “Customize your printer”.
In the Properties screen click on the Sharing Tab and check the box to share the printer and type in its share
name.
If your XP machine is an x86 OS you can install Additional Drivers before setting up the XP machine.
To find the shared folders and devices double click on the Windows 7 machine icon under Network. Here you
can see the printer connected to my Windows 7 machine is shared and also the Users Folder.
Continue into the Users folder and Public to see the shared folders, here I also created a folder called XP
Share just to keep everything in central location.
Over on your XP machine open up My Network Places to find the Windows 7 (mysticgeek-pc) shared folder.
Double click on the Share folder to find a list of shared folders in the Public folder on
Windows 7. If you have password protection enabled you will need to type in the
username and password of the user account on the Windows 7 machine first.
To set up the shared printer in XP you will need to go into Printers and Faxes from the
Start menu and kick off the Add Printer Wizard.
Now select “A network printer, or a printer attached to another computer” then hit
Next.
Next select “Connect to this printer…” and type in the path for the printer connected to the Windows 7
machine and click next.
Now click Yes to the confirmation message.
Then click Finish the printer to install and complete the Wizard.
In some cases you will need to install the x86 XP drivers for the shared printer because the Windows 7 drivers
are not compatible with XP. When everything is installed open up Printers and Faxes to find the shared
printer.
This should help you get started with sharing your files and other devices with your Windows 7
machine. When I first started I was able to see the printer on XP right away because I had a HomeGroup set
up, but once I deleted it I needed to share the printer like you would for a workgroup. You might also have to
do a couple restarts of the XP machine for it to see the shared resources on Windows 7.
La b no 4
Configuration of Cisco Catalyst Switch 3560
In this lab we will learn about
Cisco uses IOS which stands for Internetwork operating system. IOS is command line interface for
configuring switch and router. Following are steps for connecting to switch.
Connecting to Switch
- Hyperterminal
- Tera term
- Minicom
- Securecrt
Baud rate=9600
Data bits=8
Parity=None
Stop bits=1
Flow Control:None
Cisco is famous for its operating system, which uses command line interface for configuration of Switch
and router. A lot of help is available to the user just by typing a question mark at the command prompt.
Hyper terminal is no longer supported by windows, so we will use Tera term, which is free terminal
program for connecting with switch.
Example: Using of help from Cisco IOS on setting a clock on a new switch
Uqu_switch>enable
Uqu_switch#clock?
Uqu_switch#clock set ?
To see the current configuration file on switch use the following command
Uqu_switch#sh run
Which is a shortcut for Show running-configuration, we can use shortcuts for the Cisco commands only
when they are unique.
Setting a hostname
Uqu_switch#configure terminal
Uqu_switch(config)#hostname saqib_switch
But switch should be named according to some convention like. 3rdF_R1_S1 meaning that switch is on
3rd floor room 1 having a number 1.
Assigning of IP address to the VLAN interface
By default switch have only one broadcast domain. By using VLAN, switch can be divided into multiple
broadcast domains. For configuration purpose switch is assigned an IP address which is used for
configuration of switch from remote place.
Uqu_switch(config)#interface vlan1
(Changing any setting will effect only the current interface e.g. vlan1)
Uqu_switch(config-if)#end
Check the interfaces, if the interface is administratively down. Go again to global configuration mode
and issue no shutdown command to make the interface running.
Uqu_switch(config)#
Uqu_switch(config)#interfaces vlan1
Uqu_switch(config-if)#no shutdown
Uqu_switch#show startup-config
The following command shows the complete information about the version of IOS and other
information about device.
Uqu_switch#show version
After initial configuration is done now it is time to lock it down, so need security.
Go to command prompt and type telnet and then type IP address of the switch.
C:\telnet 192.168.230.2
Notice telnet will not work, because it requires password for it to work. By default it deactivated in
Windows 7. Steps for activation are given below.
Uqu_switch>enable
Uqu_switch#configure terminal
Uqu_switch(config)#exit
Uqu_switch#disable
Uqu_switch>
Now try the password set for privileged mode in the previous command
Uqu_switch>enable
Password:
Uqu_switch#show running-config
Notice: Problem with previous password is that, it can be seen in plain text in configuration file. Another
password option is to use secret password, which cannot be seen in configuration file.
Press Ctrl+Z
Now we have two passwords active on switch, secret password has higher preference over the plain text
password. All configurations can be copied to notepad and can be pasted at once in global configuration
mode.
Uqu_switch(config-line)#password cisco
Uqu_switch(config-line)#login
But still telnet is not possible, for this we have to set virtual terminal lines in configuration file (vty 0-15).
There are 15 virtual terminal lines in switch 3560, which can be used for connecting to switch from
remote place. These 15 virtual terminal lines can be used simultaneously for connecting to switch. Let’s
check how many vty lines a switch has
Uqu_switch(config)#line vty ?
Uqu_switch(config)#line vty 0 1
Uqu_switch(config-line)#login
Uqu_switch(config-line)#password cisco
Ctr+Z
Uqu_switch#
All of the telnet transaction is being done in plain text which is the main security problem. Now we will
check telnet transactions using packet sniffing software WireShark. Following are the steps
1. Open wireshark and select an interface, which is used for capturing the telnet traffic.
3. Stop the capturing and use the follow up TCP stream option from Wireshark. One can easily see all the
telnet transactions from captured traffic.
Also the virtual terminal lines vty 0 1 password can be seen easily in configuration file. Another
command can be used to encrypt the passwords.
Uqu_switch(config)#service password-encryption
Setting the Banner
Banner can be used for different copyright messages at the startup of switch or console. One such
message is “Message of the Day (Motd)”.
Uqu_switch#configure terminal
Cisco uses IOS which stands for Internetwork operating system. IOS is command line interface for
configuring switch and router. Following are steps for connecting to router.
Connecting to Router
- Tera term
- Minicom
- Securecrt
10.0.0.1
5. Set it to connect via com port with
Baud rate=9600
Data bits=8
Parity=None
Stop bits=1
Flow Control:None
Configure IP Address on Fast Ethernet 0/1
CISCO(config-if)# no shutdown
!!! Make Sure the Connectivity established b/w 10.0.0.1 and 10.0.0.10 after assign ip.
CISCO(config-line)# login
CISCO(config-line)# exit
CISCO# sh line
Configure SSH
To SSH Connectivity
UQU
Choose the size of the key modulus in the range of 360 to 2048 for your General Purpose Keys.
Choosing a key modulus greater than 512 may take a few minutes.
!!! PC 11.0.0.1
CISCO(config)# hostname R1
R1(config)# interface serial 0
R1(config-if)# no shutdown
R1(config-if)# clock rate 64000 (Clock Rate will set only DCE
Interface)
R1(config-if)# end
CISCO(config)# hostname R2
R2(config-if)# no shutdown
R2(config-if)# end
!!!!!
CISCO(config-if)# no shutdown
CISCO(config-if)# clock rate 64000 (Clock Rate will set only DCE Interface)
CISCO(config-if)# exit
CISCO(config-if)# no shutdown
CISCO(config-if)# end
!!! Assign IP on R2
R2(config-if)# no shutdown
R2(config-if)# end
R2(config)# interface ethernet 0
R2(config-if)# no shutdown
R2(config-if)# end
CISCO# sh ip route
R2# sh ip route
CISCO# sh ip route
S means Static
1 mean AD
R2# sh ip route
C:\>ping 20.0.0.1
Cisco uses IOS which stands for Internetwork operating system. IOS is command line interface for
configuring switch and router. Following are steps for connecting to switch.
Topology Diagram
Addressing table
In this lab activity, you will design and apply an IP addressing scheme for the topology shown in the
Topology Diagram. You will be given one class C address that you must subnet to provide a logical
addressing scheme for the network. You must first cable the network as shown before the configuration
can begin. Once the network is cabled, configure each device with the appropriate basic configuration
commands. The routers will then be ready for interface address configuration according to your IP
addressing scheme. When the configuration is complete, use the appropriate IOS commands to verify
that the network is working properly.
You have been given the 192.168.1.0/24 address space to use in your network design. The network
consists of the following segments:
The network connected to router R1 will require enough IP addresses to support 20 hosts.
The network connected to router R2 will require enough IP addresses to support 20 hosts.
The link between router R1 and router R2 will require IP addresses at each end of the link.
(Note: Remember that the interfaces of network devices are also host IP addresses and are included in
the above addressing scheme.)
Step 2: Consider the following questions when creating your network design.
What is the subnet mask for this network in dotted decimal format? ____________________
What is the subnet mask for the network in slash format? ____________________
1. Assign the first subnet (lowest subnet) to the network attached to R1.
1. Assign the first valid host address in first subnet to the LAN interface on R1.
3. Assign the first valid host address in second subnet to the WAN interface on R1.
4. Assign the last valid host address in second subnet to the WAN interface on R2.
5. Assign the first valid host address in third subnet to the LAN interface of R2.
Step 2: Document the addresses to be used in the table provided under the Topology
Diagram.
Step 1: Cable a network that is similar to the one in the Topology Diagram.
You can use any current router in your lab as long as it has the required interfaces as shown in the
topology.
Perform basic configuration of the R1 and R2 routers according to the following guidelines:
Configure the interfaces on the R1 and R2 routers with the IP addresses from your network design.
When you have finished, be sure to save the running configuration to the NVRAM of the router.
Configure the Ethernet interfaces of PC1 and PC2 with the IP addresses and default gateways from your
network design.
Answer the following questions to verify that the network is operating as expected.
From the host attached to R1, is it possible to ping the default gateway? __________
From the host attached to R2, is it possible to ping the default gateway? __________
From the router R1, is it possible to ping the Serial 0/0/0 interface of R2? __________
From the router R2, is it possible to ping the Serial 0/0/0 interface of R1? __________
The answer to the above questions should be yes. If any of the above pings failed, check your physical
connections and configurations. If necessary, refer to Lab 1.5.2, “Basic Router Configuration.”
__________________________________________________________________________
__________________________________________________________________________
__________________________________________________________________________
Task 7: Reflection
Are there any devices on the network that cannot ping each other?
__________________________________________________________________________
__________________________________________________________________________
What is missing from the network that is preventing communication between these devices?
__________________________________________________________________________
__________________________________________________________________________
On each router, capture the following command output to a text (.txt) file and save for future reference.
Running configuration
Routing table
Step 1: Cable a network that is similar to the one in the Topology Diagram.
You can use any current router in your lab as long as it has the required interfaces shown in the
topology.
Note: If you use 1700, 2500, or 2600 routers, the router outputs and interface descriptions will appear
different.
Perform basic configuration of the R1, R2, and R3 routers according to the following guidelines:
Step 1 Configure the interfaces on the R1, R2, and R3 routers with the IP addresses from the table.
Step 2 Configure the PCs with the IP addresses from the table.
Step 1 Use the show ip ospf neighbor command to verify information about other routers was
learned.
Step 2 Use the show ip protocols command to view information about the routing protocol.
Step 1 Use the show ip route command to view all learned networks via OSPF.
Task 9: Configure OSPF Cost
Step 1 Using the show ip route command verify that the default route was learned.
La b no 8
B a s i c E IG R P C o n f i g ur a t i o n
In this lab we will learn about
In this lab activity, you will learn how to configure the routing protocol EIGRP using the network
shown in the Topology Diagram. A loopback address will be used on the R2 router to simulate a
connection to an ISP, where all traffic that is not destined for the local network will be sent.
Some segments of the network have been subnetted using VLSM. EIGRP is a classless routing
protocol that can be used to provide subnet mask information in the routing updates. This will
allow VLSM subnet information to be propagated throughout the network.
Step 1: Cable a network that is similar to the one in the Topology Diagram.
This activity begins with an initial network in the logical workspace.
Perform basic configuration of the R1, R2, and R3 routers according to the following guidelines:
Configure the Ethernet interfaces of PC1, PC2, and PC3 with the IP addresses and default
gateways from the table under the Topology Diagram.
R1(config)#router eigrp 1
R1(config-router)#network 172.16.0.0
The router will begin to send EIGRP update messages out each interface belonging to the
172.16.0.0 network. EIGRP updates will be sent out of the FastEthernet0/0 and Serial0/0/0
interfaces because they are both on subnets of the 172.16.0.0 network.
Step 3: Configure the router to advertise the 192.168.10.4/30 network attached to the
Serial0/0/1 interface.
Use the wildcard-mask option with the network command to advertise only the subnet and not
the entire 192.168.10.0 classful network.
Note: Think of a wildcard mask as the inverse of a subnet mask. The inverse of the subnet
mask 255.255.255.252 is 0.0.0.3. To calculate the inverse of the subnet mask, subtract the
subnet mask from 255.255.255.255:
255.255.255.255
– 255.255.255.252 Subtract the subnet mask
----------------------
0. 0. 0. 3 Wildcard mask
R1(config-router)# network 192.168.10.4 0.0.0.3
When you are finished with the EIGRP configuration for R1, return to privileged EXEC mode
and save the current configuration to NVRAM.
Step 1: Enable EIGRP routing on the R2 router using the router eigrp command.
Use an autonomous system number of 1.
R2(config)#router eigrp 1
Step 2: Use the classful address 172.16.0.0 to include the network for the FastEthernet0/0
interface.
R2(config-router)#network 172.16.0.0
Notice that DUAL sends a notification message to the console stating that a neighbor
relationship with another EIGRP router has been established.
Step 3: Configure the R2 router to advertise the 192.168.10.8/30 network attached to the
Serial0/0/1 interface.
1. Use the wildcard-mask option with the network command to advertise only the subnet
and not the entire 192.168.10.0 classful network.
Step 4: Configure EIGRP on the R3 router using the router eigrp and network commands.
2. Use the classful network address for the network attached to the FastEthernet0/0
interface.
3. Include the wildcard masks for the subnets attached to the Serial0/0/0 and Serial 0/0/1
interfaces.
4. When you are finished, return to privileged EXEC mode.
R3(config)#router eigrp 1
R3(config-router)#network 192.168.1.0
R3(config-router)#network 192.168.10.4 0.0.0.3
R3(config-router)#network 192.168.10.8 0.0.0.3
R3(config-router)#
Notice that when the networks for the serial links from R3 to R1 and R3 to R2 are added to the
EIGRP configuration, DUAL sends a notification message to the console stating that a neighbor
relationship with another EIGRP router has been established.
R1#show ip protocols
Notice that the output specifies the autonomous system number used by EIGRP. Remember,
the autonomous system number must be the same on all routers for EIGRP to establish
neighbor adjacencies and share routing information.
R1#show ip route
Notice that the 172.16.0.0/16 parent network is variably subnetted with three child routes using
either a /24 or /30 mask. Also notice that EIGRP has automatically included a summary route to
Null0 for the 172.16.0.0/16 network. The 172.16.0.0/16 route does not actually represent a path
to reach the parent network, 172.16.0.0/16. If a packet destined for 172.16.0.0/16 does not
match one of the level 2 child routes, it is sent to the Null0 interface.
The 192.168.10.0/24 Network is also variably subnetted and includes a Null0 route.
For this lab, the link between R1 and R2 will be configured with a bandwidth of 64 kbps, and the
link between R2 and R3 will be configured with a bandwidth of 1024 kbps. Use the bandwidth
command to modify the bandwidth of the Serial interfaces of each router.
R1 router:
R1(config)#interface serial0/0/0
R1(config-if)#bandwidth 64
R2 router:
R2(config)#interface serial0/0/0
R2(config-if)#bandwidth 64
R2(config)#interface serial0/0/1
R2(config-if)#bandwidth 1024
R3 router:
R3(config)#interface serial0/0/1
R3(config-if)#bandwidth 1024
Note: The bandwidth command only modifies the bandwidth metric used by routing protocols,
not the physical bandwidth of the link.
Step 3: Verify the bandwidth modifications.
Use the show ip interface command to verify that the bandwidth value of each link has
been changed.
Note: Use the interface configuration command no bandwidth to return the bandwidth to its
default value.
Step 1: Examine the successors and feasible distances in the routing table on R2.
R2#show ip route
A successor is a neighboring router that is currently being used for packet forwarding. A
successor is the least-cost route to the destination network. The IP address of a successor is
shown in a routing table entry right after the word “via”.
What is the IP address and name of the successor router in this route?
________________________________________
Feasible distance (FD) is the lowest calculated metric to reach that destination. FD is the metric
listed in the routing table entry as the second number inside the brackets.
A feasible successor is a neighbor who has a viable backup path to the same network as the
successor. In order to be a feasible successor, R1 must satisfy the feasibility condition. The
feasibility condition (FC) is met when a neighbor’s reported distance (RD) to a network is less
than the local router’s feasible distance to the same destination network.
Use the [network] parameter of the show ip eigrp topology command to view detailed
EIGRP topology information for the 192.16.0.0 network.
________________________________________
________________________________________
________________________________________
What is the reported distance for 192.168.1.0 from the feasible successor?
________________________________________
________________________________________
Why is the R1 router (192.168.10.5) the only successor for the route to the 172.16.0.0/16
network?
____________________________________________________________________________
____________________________________________________________________________
____________________________________________________________________________
__________________________________________________________
Notice that the reported distance from R2 is higher than the feasible distance from R1.
Step 3: Disable automatic summarization on all three routers with the no auto-
summary command.
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config)#interface loopback1
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#interface loopback2
R3(config-if)#ip address 192.168.3.1 255.255.255.0
Step 2: Add the 192.168.2.0 and 192.168.3.0 networks to the EIGRP configuration on R3.
R3(config)#router eigrp 1
R3(config-router)#network 192.168.2.0
R3(config-router)#network 192.168.3.0
R3(config)#interface serial0/0/0
R3(config-if)#ip summary-address eigrp 1 192.168.0.0 255.255.252.0
R3(config-if)#interface serial0/0/1
R3(config-if)#ip summary-address eigrp 1 192.168.0.0 255.255.252.0
R3(config-if)#
What is wireshark
Wireshark is a network protocol analyzer, also known as a network sniffer. Formerly known as
Ethereal, wireshark is computer application that captures and decodes packets of information
from a network. “Wireshark can capture live network traffic or read data from a file and translate
the data to be presented in a format the user can understand”.
Why Wireshark
Wireshark is a valuable tool for administrators that allow them to monitor all traffic that passes
on a network. It is very useful for analyzing, diagnosing and troubleshooting problems that may
occur.
1. Data can be captured from a network connection or read from previous records of captured
packets.
2. Live data can be read from Ethernet, FDDI, PPP, token ring, IEEE 802.11, classical IP over
ATM, and loopback interfaces (at least on some platforms; not all of those types are
supported on all platforms ).
3. Captured files can be programmatically edited or converted via command-line switches to
the “editcap” program.
4. Captured network data can be browsed via a GUI, or via the terminal((command line)
version of the utility tshark.
5. Display filters can also be used to selectively highlight and color packet summay
information.
6. Data display can be refined using a display filter
Hundreds of protocols can be dissected.
Wireshark has a friendly graphical user interface that makes it easier for the to analyze and
diagnose packets that passing through the network. No data will initially be displayed when
the user runs wireshark.
The environment and usage of wireshark will be explained further in this document.
To start capturing packets you need to select the interface which is connected to the
internet. This can be done by choosing Capture>>Interfaces from the Menu bar
The different interfaces available that WinPcap driver sees in the machine are shown and you can either
click start or click options for more options regarding capturing packets before starting the capture.
The following figure represents the Capture Option's Window