Steps For BRAS Configuration

Download as pdf or txt
Download as pdf or txt
You are on page 1of 7

To set up a **BRAS (Broadband Remote Access Server)** on a Juniper MX480, several key

components and protocols need to be configured. The basic goal of a BRAS is to manage
and authenticate broadband subscribers, aggregate subscriber tra ic, and provide
necessary services such as IP addressing, authentication, and routing. Below are the
essential steps to configure a BRAS on the MX480:

### Step-by-Step Configuration of BRAS on MX480:

#### 1. **Basic System Configuration**

Start with setting up the device's basic system settings, including hostname, login
credentials, and management services.

```bash

set system host-name BRAS

set system root-authentication encrypted-password <encrypted-password>

set system services ssh root-login deny

set system services ftp

set system syslog file messages any notice

```

#### 2. **Interface Configuration (Physical and Logical)**

Configure the physical and logical interfaces. You will define the **physical interfaces**
that connect to the uplinks (core network) and the **subscriber-facing interfaces** that will
handle customer tra ic (PPPoE or IPoE). You will also configure **aggregated Ethernet
interfaces** for redundancy (LACP).

`Example

# Configure physical interfaces


set interfaces xe-0/0/0 description "Uplink to Core Network"

set interfaces xe-0/0/1 description "Subscriber Access Interface"

# Example of Aggregated Ethernet interface for redundancy

set interfaces ae0 description "Uplink to Core"

set interfaces ae0 aggregated-ether-options lacp active

set interfaces ae0 unit 0 family inet address 10.1.1.1/30

```

#### 3. **Define VLANs for Subscribers**

If using VLANs for subscribers (typical in BRAS setups), configure the VLAN tagging and
logical interfaces.

`Example

set interfaces ae1 vlan-tagging

set interfaces ae1 unit 100 vlan-id 100 family inet address 10.100.1.1/24

```

#### 4. **Configure PPPoE or IPoE for Subscriber Authentication**

BRAS typically supports **PPPoE (Point-to-Point Protocol over Ethernet)** for DSL
subscribers and **IPoE (IP over Ethernet)** for other broadband technologies (e.g., Fiber,
DHCP-based).

##### PPPoE Configuration:

To configure **PPPoE**, you need to enable it on the interface and specify the appropriate
**authentication and subscriber profiles**.
`Example

# Enable PPPoE on interface ae5

set interfaces ae5 description "PPPoE Interface"

set interfaces ae5 unit 300 vlan-id 300 family inet

# Configure PPPoE service

set access profile pppoe_profile authentication-order pap chap

set access profile pppoe_profile client pppoe radius-service my-radius

# Configure dynamic subscriber interfaces

set dynamic-profiles PPPoE dynamic-profile-name pppoe_profile

```

##### IPoE Configuration:

For **IPoE**, you would typically enable **DHCP** services to assign IP addresses to
subscribers.

`Example

# Enable DHCP service on the subscriber interface

set access-internal dhcp-pool pool1 address-range low 10.100.100.10 high


10.100.100.100

set access-internal dhcp-pool pool1 server-identifier 10.100.1.1

```

#### 5. **Radius Authentication for Subscribers**

Integrating with an external **RADIUS server** is key for subscriber authentication,


authorization, and accounting.
`Example

set access radius-server 192.168.1.1 secret my-secret

set access radius-server 192.168.1.1 accounting-port 1813

```

Ensure the correct **PPP, IPoE**, or **DHCP attributes** are sent to the RADIUS server for
subscriber management.

#### 6. **Configure IP Address Pools (For PPPoE or IPoE)**

You will need to assign IP addresses to the subscribers. You can either use a **local IP
address pool** or **assign via RADIUS/DHCP**.

##### Local IP Pool Example:

`Example

set access-internal address-assignment pool subscriber-pool family inet network


192.168.1.0/24

set access-internal address-assignment pool subscriber-pool family inet address-range


low 192.168.1.10 high 192.168.1.100

```

#### 7. **Configure NAT for Subscribers**

Network Address Translation (NAT) is often required to provide internet access for
subscribers. Typically, **CGNAT (Carrier Grade NAT)** is used.

```bash

set services nat pool cg-nat-pool address-range low 100.100.100.1 high 100.100.100.254
set services nat rule-set nat-rs from zone trust

set services nat rule-set nat-rs rule rule-1 match-direction input

set services nat rule-set nat-rs rule rule-1 match destination-address 0.0.0.0/0

set services nat rule-set nat-rs rule rule-1 then source-nat pool cg-nat-pool

```

#### 8. **Configure Routing (BGP/Static Routes)**

You need to advertise subscriber routes to the core network or upstream ISPs via **BGP**
or static routing.

`Example

# Static Route Example

set routing-options static route 0.0.0.0/0 next-hop 10.1.1.2

# BGP Configuration Example

set protocols bgp group ebgp-to-core type external

set protocols bgp group ebgp-to-core peer-as 64512

set protocols bgp group ebgp-to-core neighbor 10.1.1.2 description "Core Router"

```

#### 9. **Configure Firewall Policies**

Protect the BRAS by configuring **firewall filters** to restrict unwanted tra ic and ensure
security for subscribers.

`Example

set firewall family inet filter INPUT-FILTER term allow-pppoe from protocol pppoe

set firewall family inet filter INPUT-FILTER term allow-pppoe then accept
set firewall family inet filter INPUT-FILTER term deny-all then discard

```

#### 10. **Configure Redundancy (Optional)**

For high availability, configure **dual Routing Engines** and other redundancy options
such as **graceful Routing Engine switchover (GRES)**.

`Example

set chassis redundancy graceful-switchover

set chassis redundancy routing-engine 0 master

set chassis redundancy routing-engine 1 backup

```

#### 11. **Configure Subscriber Accounting**

Configure accounting logs and integrate with the **RADIUS server** for tracking subscriber
usage.

`Example

set system accounting events interactive-commands

set access radius-accounting server 192.168.1.1 secret accounting-secret

```

#### 12. **Commit the Configuration**

Finally, after configuring the BRAS, commit the configuration to apply the changes.

`Example

commit
```

### High-Level Overview of the BRAS Setup Process:

1. **Basic device configuration** (hostname, login, services).

2. **Interface configuration** (physical, logical, VLANs).

3. Configure **PPPoE/IPoE** for subscriber access.

4. **RADIUS integration** for authentication and accounting.

5. Set up **IP address pools** for subscribers.

6. Configure **NAT** to translate private IP addresses to public ones.

7. **Routing configuration** (static or dynamic with BGP).

8. Apply **firewall policies** to protect BRAS and subscribers.

9. Ensure **redundancy and high availability** (optional).

10. Set up **accounting** for subscriber usage.

11. **Commit** the configuration.

### Conclusion:

The above steps form the basis of configuring a BRAS on a Juniper MX480, providing
subscriber management and aggregation services. Depending on your network and
requirements, additional steps such as multicast support, QoS, or subscriber
management profiles might be necessary.

You might also like