Bab1 Compressed
Bab1 Compressed
Bab1 Compressed
1
CHAPTER
INFRASTRUCTURE
DESIGN
Chapter Outline
Introduction 1-4 Routed Network
1-1 Physical Network Design Summary
1-2 IP Subnet Design Questions and Problems
1-3 VLAN Network
Objectives
• Understand the purpose of the three layers • Understand the process of configuring a
of a campus network design VLAN
• Understand the issue of data flow and select- • Understand the issues of configuring the
ing the network media Layer 3 routed network
• Develop techniques for IP allocation and sub-
net design
Key Terms
core show interface status show ip interface brief (sh
distribution layer trunk port ip int br)
access layer Inter-Switch Link (ISL) no switchport
CIDR Switchport mode trunk secondary IP address
ISP switchport trunk encapsu- InterVLAN routing
intranets lation dot1q router on a stick
NAT switchport trunk encapsu- SVI
PAT lation isl DS
Overloading switchport trunk allowed CSU/DSU
vlan vlan_id AMI
supernet
show interfaces trunk B8ZS
gateway
network address Minimum Ones Density
broadcast domain
logical address HDLC
flat network
router interface PPP
VLAN (virtual LAN)
routing table WIC
port-based VLAN
subnet, NET VWIC
tag-based VLAN
multilayer switch (MLS) service-module t1
protocol-based VLAN
wire speed routing show controller t1 slot/
VLAN ID
routed network port
802.1Q
Layer 3 network ATM
static VLAN
SONET Virtual Path Connection
dynamic VLAN
WAN (VPC)
show vlan
terminal monitor (term Virtual Channel Connection
vlan database
mon) (VCC)
vlan vlan_id
terminal no monitor SVC
show vlan name vlan-name
(term no mon) VPI
interface vlan 1
VCI
3
INTRODUCTION
The objective of this chapter is to examine the computer networking issues
that arise when planning a campus network. The term campus network applies
to any network that has multiple LANs interconnected. The LANs are typi-
cally in multiple buildings that are close to each other and interconnected
with switches and routers. This chapter looks at the planning and designs of
a simple campus network, including network design, IP subnet assignment,
VLAN configuration, and routed network configuration.
The basics of configuring the three layers of a campus LAN (core, distribu-
tion, and access) are first examined in Section 1-1. This section also ad-
dresses the important issues of data flow and selecting the proper network
media. Section 1-2 examines IP allocation and subnet design. Section 1-3
discusses the VLAN network, including a step-by-step process of how to con-
figure a VLAN, which provides an introduction to the basic switch commands
and the steps for configuring a static VLAN. Section 1-4 examines the Layer 3
routed network. This section explores the functions of the router and includes
configuration examples in different scenarios.
* Layer 3 switches
Switch A Switch B
Core
segment segment
A1 A2 B1 B2 C1 C2 D1 D2
FIGURE 1-1 The core, distribution, and access layers of a campus network
Distribution Layer
The distribution layer in the network is the point where the individual LANs con-
nect to the campus network routers or Layer 3 switches. Routing and filtering poli- Distribution Layer
cies are more easily implemented at the distribution layer without having a negative Point where the
individual LANs connect
impact on the performance of the network data traffic. Also, the speed of the net-
together.
work data connections at the distribution layer is typically slower than at the core.
For example, connection speeds at the core should be the highest possible, such as
1 or 10 gigabits, where the data speed connections at the distribution layer could be
100 Mbps or 1 gigabit. Figure 1-1 shows the connections to the access and core lay-
ers via the router’s Ethernet interfaces.
NOTE
Hubs are not recommended at all in modern computer networks.
Data Flow
An important networking issue is how data traffic flows in the core, distribution,
and access layers of a campus LAN. In reference to Figure 1-1, if computer A1
in LAN A sends data to computer D1 in LAN D, the data is first sent through the
switch in LAN A and then to Router A in the distribution layer. Router A then for-
wards the data to the core switches, Switch A or Switch B. Switch A or Switch B
then forwards the data to Router C. The data packet is then sent to the destination
host in LAN D.
The following are some questions often asked when setting up a network that im-
plements the core, distribution, and access layers:
• In what layer are the campus network servers (web, email, DHCP, DNS,
and so on) located? This varies for all campus networks, and there is not a
definitive answer. However, most campus network servers are located in the
access layer.
• Why not connect directly from Router A to Router C at the distribution
layer? There are network stability issues when routing large amounts of net-
work data traffic if the networks are fully or even partially meshed together.
This means that connecting routers together in the distribution layer should be
avoided.
• Where is the campus backbone located in the layers of a campus net-
work? The backbone of a campus network carries the bulk of the routed data
traffic. Based on this, the backbone of the campus network connects the dis-
tribution and the core layer networking devices.
The final steps in designing the IP subnet is to assign an IP address to the interface
that will serve as the gateway out of each subnet.
Intranets
Internetwork that Today, only public Class C addresses are assigned by ISPs, and most of them are
provides file and not even a full set of Class C addresses (256 IP addresses). A lot of ISPs partition
resource sharing. their allotted IP space into smaller subnets and then, in turn, provide those smaller
portions to the customers. The bottom line is the limited number of public IP ad-
NAT dresses are now a commodity on the Internet, and it is important to note that there
Network Address are fees associated with acquiring an IP range from an ISP.
Translation. A technique
used to translate an Not many institutions or businesses have the luxury of using public IP addresses
internal private IP inside their network anymore. This is because the growing number of devices being
address to a public IP used in a network exceeds the number of public IP addresses assigned to them. The
address. solution is that most networks are using private IP addresses in their internal net-
PAT work. Private addresses are IP addresses set aside for use in private intranets. An
Port Address Translation. intranet is an internal internetwork that provides file and resource sharing. Private
A port number is addresses are not valid addresses for Internet use, because they have been reserved
tracked with the client for internal use and are not routable on the Internet. However, these addresses can
computer’s private be used within a private LAN (intranet) to create the internal IP network.
address when translating
to a public address. The private IP addresses must be translated to public IP addresses using techniques
like NAT (Network Address Translation) or PAT (Port Address Translation) before
Overloading being routed over the Internet. For example, computer 1 in the home network (see
Where NAT translates the Figure 1-2) might be trying to establish a connection to an Internet website. The
home network’s private wireless router uses NAT to translate computer 1’s private IP address to the public
IP addresses to a single IP address assigned to the router. The router uses a technique called overloading,
public IP address.
where NAT translates the home network’s private IP addresses to the single public
to ISP
2
Wireless Router
(Access Point/Switch/
Broadband Modem)
Router
192.168.0.66 192.168.0.1 128.123.246.55 : 1973
FIGURE 1-3 This example shows the three data connections originating from the home
network of 192.168.0.0/24
Simply put, the IP network must be designed to accommodate the current demand,
and it must be designed to accommodate future growth. Once the size of a network
is determined, a subnet can be assigned. In the case of a single network, the design
is not too complicated. For example, if the network needs to be able to accommo-
date 150 network devices, an entire Class C address, like 192.168.1.0/24, can be
assigned to the network. This will handle the current 150 network devices and leave
enough room for growth. In this example, 104 additional IP address will be avail-
able for future growth.
When allocating IP address blocks, a table like Table 1-2 can be used to provide the
CIDR for the most common subnet masks and their corresponding number of avail-
able IP addresses.
Even with a much smaller network, like the home network, where only a handful
of network computers and peripherals are present, an entire Class C private address
is generally allocated to the home network. In fact, most home routers are precon-
figured with a private Class C address within the 192.168.0.0–192.168.0.255 range.
This technique is user friendly and easy to use and sets aside private IP addresses
for internal network use. This technique virtually guarantees that users will never
have to worry about subnetting the CIDR block.
For a bigger network that must handle more than 254 network devices, a supernet
can be deployed. A supernet is when two or more classful contiguous networks Supernet
are grouped together. The technique of supernetting was proposed in 1992 to Two or more classful
eliminate the class boundaries and make available the unused IP address space. contiguous networks are
Supernetting allows multiple networks to be specified by one subnet mask. In grouped together.
other words, the class boundary could be overcome. For example, if the network
needs to be able to accommodate 300 network devices, two Class C networks, like
192.168.0.0/24 and 192.168.1.0/24, can be grouped together to form a supernet
of 192.168.0.0/23, which can accommodate up to 510 network devices. As shown
in Table 1-2, a /23 CIDR provides 512 available IP addresses. However, one IP is
reserved for the network address and another one is reserved for the network broad-
cast address. Therefore, a /23 CIDR yields 512 – 2 = 510 usable host IP addresses.
Example 1-1
Figure 1-4 shows three different networks with different size requirements. The
needed capacity (number of devices) for each network is specified in the figure.
Your task is to determine the CIDR block required for each network that will
satisfy the number of expected users. You are to use Class C private IP addresses
when configuring the CIDR blocks.
Interconnect LAN B1
Capacity: 800 devices
RouterA RouterB
LAN B2
LAN A Server Network
Capacity: 300 devices No more than 80 servers
Solution:
For LAN A, a CIDR block that can handle at least 300 networking devices must
be provided. In this case, two contiguous Class C networks of 192.168.0.0/24 and
192.168.1.0/24 can be grouped together to form a 192.168.0.0/23 network. Refer-
ring to Table 1-2, a /23 CIDR with a subnet mask of 255.255.254.0 provides 512
IP addresses which more than satisfies the required 300 networking devices.
The next question is to determine what the network address is for LAN A. This can
be determined by ANDing the 255.255.254.0 subnet mask with 192.168.0.0 and
192.168.1.0.
192. 168. 0. 0 192. 168. 1. 0
255. 255. 254. 0 (/23) 255. 255. 254. 0 (/23)
192. 168. 0. 0 192. 168. 0. 0
This shows that applying the /23 [255.255.254.0] subnet mask to the specified IP
address places both in the same 192.168.0.0 network. This also means that this
CIDR block does not cross boundaries, because applying the subnet mask to each
network address places both in the same 192.168.0.0 network.
Based on this information, the next Class C range 192.168.4.0/22 is selected. This
yields a nonoverlapping network of 192.168.4.0, so the subnet 192.168.4.0/22 is a
valid for this network:
192.168.4.0
255.255.252.0 (/22)
192.168.4.0 is not the same subnet; therefore, this is an acceptable CIDR block.
Recall that the CIDR for LANB1 is a /22 and is equivalent to grouping four Class C
networks. This means that LANB1 uses the following Class C networks:
192.168.4.0
192.168.5.0
192.168.6.0
192.168.7.0
Gateway
Data Data
enter LAN exit
For LAN A in Example 1-1, the IP address 192.168.0.0 is already reserved as the
network address, and the IP address 192.168.0.255 is reserved as the broadcast
address. This leaves any IP address within the range 192.168.0.1–192.168.0.254
available for use for the gateway address. Choosing the gateway IP address is not
an exact science. Generally, the first IP address or the last IP address of the avail-
able range is chosen. Whatever convention is chosen, it should apply to the rest of
the subnets for the ease of management. Once the gateway IP address is chosen,
this IP address is reserved and is not to be used by any other devices in the subnet.
Otherwise, an IP conflict will be introduced. The following is an example of how
the gateway IP addresses could be assigned to the LANs in Example 1-1.
Network Gateway
LAN A 192.168.0.1
LAN B1 192.168.4.1
LAN B2 192.168.8.1
2nd floor
1st floor
FIGURE 1-6 Three floors of a building interconnected using switches to form one large LAN
VLAN 2 VLAN 3
Ports 2,3,4 Ports 6,7,8
Dynamic VLAN • Dynamic VLAN: Ports are assigned to a VLAN based on either the computer’s
MAC address or the username of the client logged onto the computer. This
Ports are assigned to a
VLAN based on either means that the system has been previously configured with the VLAN as-
the computer’s MAC signments for the computer or the username. The advantage of this is the
address or the username username and/or the computer can move to a different location, but VLAN
of the client logged onto membership will be retained.
the computer.
VLAN Configuration
This section demonstrates the steps for configuring a static VLAN. In this example,
the ports for VLAN 2 (Sales) and VLAN 3 (Engineering) will be defined. This re-
quires that VLAN memberships be defined for the required ports. The steps and the
commands will be demonstrated.
The show vlan command can be used to verify what ports have been defined for the
show vlan switch. By default, all ports are assigned to VLAN 1. An example using the show
Used to verify what vlan command is provided next.
ports have been defined
for the switch. SwitchA# show vlan
On newer Cisco switches, users will get the following message that the command
vlan database is being deprecated:
% Warning: It is recommended to configure VLAN from config mode,
as VLAN database mode is being deprecated. Please consult user
documentation for configuring VTP/VLAN in config mode.
Cisco has moved away from the VLAN database-style command to an IOS global
command. Similarly to other IOS global commands, the switch must be in the con-
figuration mode (config)#. However, the concept remains the same that a VLAN
must be created for it to be activated and ready for use. The steps for creating the
VLAN on newer Cisco switches are as follows:
SwitchA# conf t
SwitchA(config)#vlan 2
SwitchA(config-vlan)#name Sales
SwitchA(config-vlan)#vlan 3
SwitchA(config-vlan)#name Engineering
SwitchA(config-vlan)#exit
SwitchA(config)#exit
To start configuring a VLAN, one must specify which VLAN needs to be config-
vlan [vlan_id]
ured using the vlan [vlan_id] command. If the specific VLAN does not exist, this
command will create the VLAN as well. As shown in the preceding example, the The IOS global command
used to create VLAN ID.
command vlan 2 is entered to configure vlan 2 and then the command name Sales
is entered to configure the name associated to the VLAN. The similar steps are
done for VLAN 3 with the name Engineering.
This shows that both the Sales and Engineering VLANs have been created. In the
next steps, ports will be assigned to the newly created VLANs. This requires that
the configuration mode be entered and each FastEthernet interface (port) must be
assigned to the proper VLAN using the two commands switchport mode access
and switchport access vlan vlan-id. An example is presented for FastEthernet in-
terface 0/2 being assigned to VLAN 2 on a Cisco switch:
SwitchA#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SwitchA(config)#int fa 0/2
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 2
SwitchA(config-if)#end
The next step is used to verify that FastEthernet 0/2 has been assigned to the Sales
VLAN (VLAN2). This can be verified using the show vlan brief command, as
shown. This command only displays the interfaces assigned to each VLAN:
SwitchA#sh vlan brief
The next steps are to assign ports 3 and 4 to the Sales VLAN (VLAN 2) and ports
6,7,8 to Engineering (VLAN 3). Once this is completed, the port assignments can
be verified using the show vlan command, as shown:
You can look specifically at the assignments for only one of the VLANs by entering
the command show vlan name vlan-name, where vlan-name is the name assigned show vlan name vlan-
name
to the VLAN. Note that the name is case-sensitive. You can also use the number of
The command to look
the VLAN instead of using the command show vlan id vlan-id. Examples of both
specifically at only one
are presented:
of the VLANs.
SwitchA#show vlan name Engineering
Switch#show vlan id 3
Note that the IP address is being set for VLAN 1. The interface for the switch is
also enabled at this same point using the no shutdown command, as shown. In
order for the interface VLAN to be up, at least one switch port in the VLAN must
The overall configuration of the switch can be viewed using the show running-
config (sh run) command, as shown. (Only a part of the configuration is dis-
played.)
Switch#sh run - -
Building configuration...
The running-configuration for the switch shows that the FastEthernet interfaces
have been assigned to the proper VLANs. Additionally, this shows that an IP ad-
dress has been assigned to the default interface VLAN1.
This portion of the text has demonstrated the steps for creating a static VLAN. Both
Sales and Engineering VLANs were created, and specific ports on the switch were
assigned to the respective VLANs. Unassigned ports remained as part of the default
VLAN 1.
VLAN Tagging
This section explores the concept of VLAN tagging (802.1Q) and demonstrates
the steps required for this configuration. The concept of VLAN tagging can be ex-
plained using the example network shown in Figure 1-8. In this network, the Sales
team is spread out in two different buildings. Therefore, the Sales VLAN network
must be available in both buildings. Each building has its own network switch, and
both switches are connected via one physical link.
802.1Q/Trunk Port
FIGURE 1-8 An example of a scenario with two VLANS spread across two buildings
In a scenario like this, not only is it necessary to have the same Sales VLAN run-
Trunk Port ning on both building switches, it is also important to have members of the same
A switch interface or VLAN being able to communicate with each other across buildings and to adhere
port configured to carry to the same VLAN restrictions. To accomplish this, a technique called VLAN tag-
multiple VLANs.
ging is used. VLAN tagging is a technique deployed on a switch interface to carry
Inter-Switch Link Ethernet frames of multiple VLANs. The interface must connect to another switch
(ISL) port, router port, or network device that understands VLAN tagging, and both sides
The Cisco proprietary must agree on the VLAN tagging protocol.
VLAN tagging protocol.
The standard protocol for VLAN tagging is IEEE 802.1Q. This standard protocol
is widely supported by every switch manufacturer, as well as Cisco. A switch inter-
face or port configured to carry traffic for multiple VLANs is often referred to as
a trunk port. The term was made famous by Cisco, and it is used explicitly as the
VLAN tagging command in Cisco switches. Note that Cisco has its own proprietary
VLAN tagging protocol called Inter-Switch Link (ISL). The big difference between
ISL and 802.1Q is how the frame is treated. In ISL, every Ethernet frame is encap-
sulated within a 26-Byte header containing the VLAN ID and a 4 Byte CRC at the
end. This makes the size of an ISL frame bigger than an 802.1Q frame, as discussed
next.
To accomplish the VLAN tagging of the Ethernet frames, IEEE 802.1Q simply
inserts additional data to the Ethernet frame header, as shown in Figure 1-9. An
802.1Q tag is a 4-Byte tag field that is inserted between the Source Address field
and the Ethernet Type/Length field. By inserting an additional 4-Byte field, the
Ethernet frame size is increased. Its minimum frame size is now increased from 64
Bytes to 68 Bytes, and its maximum frame size is now increased from 1,518 Bytes
to 1,522 Bytes. Figure 1-9 also provides a detailed calculation of the Ethernet frame
size. Because of the additional tag field and the increased frame size, it is important
that both sides of the link be compatible. Otherwise, the tagged Ethernet frames
will not be understood and, therefore, the frames will be dropped by a non-802.1Q-
compliant interface.
56 bits 8 bits 48 bits 48 bits 8 bits 46 Bytes – 1500 Bytes 16 bits 96 bits
(8 Bytes) (2 B) (6 Bytes) (6 Bytes) (2 B) (4 Bytes) (12 Bytes)
56 bits 8 bits 48 bits 48 bits 16 bits 8 bits 46 Bytes – 1500 Bytes 16 bits 96 bits
(8 Bytes) (2 B) (6 Bytes) (6 Bytes) (4 Bytes) (2 B) (4 Bytes) (12 Bytes)
FIGURE 1-9 Typical Ethernet frame versus Ethernet frame with 802.1Q tag
The command show vlan also exists on the HP switches, but the output result is
different than the one produced from Cisco switches. The HP’s show vlan com-
mand does not provide ports with VLAN membership, while the Cisco command
does:
SwitchHP# show vlan
Status and Counters - VLAN Information
802.1Q VLAN ID : 2
Name : Sales
Status : Port-based Voice : No
Jumbo : No
On HP switches and other switch manufacturers, the command syntax for enabling
a port to carry 802.1Q tagged frames is basically the same. On HP switches, there is
not a trunk command. The step is to simply assign tagging ability to the switch port
by issuing the command tagged port_number. Because this is a non-Cisco switch,
802.1Q is the only VLAN tagging protocol that can be used. The following com-
mand sequence demonstrates how to configure an interface port 24 on an HP switch
as a 802.1Q VLAN tagging port:
SwitchHP# conf
SwitchHP(config)# vlan 1
SwitchHP(vlan-1)# tagged 24
SwitchHP(vlan-1)# exit
SwitchHP(config)# vlan 2
SwitchHP(vlan-2)# tagged 24
SwitchHP(vlan-2)# exit
Unlike Cisco switches where an 802.1Q is configured at the interface level, the tag-
ging configuration is done at the VLAN level on HP switches. Port 24 is designated
as tagged port for both VLAN 1 and VLAN 2, which enables it to carry VLAN
1 and VLAN 2 frames. Generally, untagged ports belong to one specific VLAN,
while tagged ports can belong to one or more VLANs.
Router
The router is a powerful networking device used to interconnect LANs. The router
is a Layer 3 device in the OSI model, which means the router uses the network ad- Network Address
dress (Layer 3 addressing) to make routing decisions regarding forwarding data Another name for the
packets. In the OSI model, the Layer 3, or network, layer responsibilities include Layer 3 address.
handling of the network address. The network address is also called a logical ad- Logical Address
dress, rather than being a physical address (such as the MAC address, which is em- This describes the IP
bedded into the network interface card [NIC]). The logical address describes the IP address location of the
address location of the network and the address location of the host in the network. network and the address
location of the host in
Essentially, the router is configured to know how to route data packets entering or the network.
exiting the LAN. This differs from the bridge and the Layer 2 switch, which use the
Ethernet address for making decisions regarding forwarding data packets and only
know how to forward data to hosts physically connected to their ports.
Routers are used to interconnect LANs in a campus network. Routers can be used
to interconnect networks that use the same protocol (for example, Ethernet), or they Router Interface
can be used to interconnect LANs that are using different Layer 2 technologies, The physical connection
such as an Ethernet, ATM, T1, and so on. Routers also make it possible to intercon- where the router
connects to the network.
nect to LANs around the country and the world and interconnect to many different
networking protocols. The router ports are bidirectional, meaning that data can en-
ter and exit the same router port. Often, the router ports are called the router inter-
face, which is the physical connection where the router connects to the network.
The network provided in Figure 1-10 is an example of a simple three-router campus
network. This configuration enables data packets to be sent and received from any
host on the network after the routers in the network have been properly configured.
For example, computer A1 in LAN A could be sending data to computer D1 in
LAN D. This requires that the IP address for computer D1 is known by the user
sending the data from computer A1. The data from computer A1 will first travel
to the switch where the data is passed to Router A via the FA0/0 FastEthernet data
port. Router A will examine the network address of the data packet and use con-
figured routing instructions stored in the router’s routing tables to decide where
to forward the data. Router A determines that an available path to Router C is via
the FA0/2 FastEthernet port connection. The data is then sent directly to Router C.
Router C determines that the data packet should be forwarded to its FA0/0 port to
reach computer D1 in LAN D. The data is then sent to D1. Alternatively, Router
A could have sent the data to Router C through Router B via Router A’s FA0/1
FastEthernet port.
segment
RouterA E2 RouterB RouterC E2
10.10.200.0 NET 10.10.150.0 NET
E1 E2 E3 E1
E0 E0 E1 E0
segment segment
A1 A2 B1 B2 C1 C2 D1 D2
RouterA Port Addresses (LAN A) RouterB Port Addresses (LAN B) RouterB Port Addresses (LAN C) RouterC Port Addresses (LAN D)
Subnet Mask 255.255.255.0 Subnet Mask 255.255.255.0 Subnet Mask 255.255.255.0 Subnet Mask 255.255.255.0
Delivery of the information over the network was made possible by the use of an IP
Routing Table address and routing table. Routing tables keep track of the routes used for forward-
Keeps track of the routes ing data to its destination. RouterA used its routing table to determine a network
to use for forwarding data path so computer A1’s data could reach computer D1 in LAN D. After the data
data to its destination.
packet arrived on Router C, an ARP request is issued by Router C to determine the
MAC address of computer D1. The MAC address is then used for final delivery of
the data to computer D1.
If Router A determines that the network path to Router C is down, Router A can
route the data packet to Router C through Router B. After Router B receives the
data packet from Router A, it uses its routing tables to determine where to forward
the data packet. Router B determines that the data needs to be sent to Router C.
Router B will then use its FA0/3 FastEthernet port to forward the data to Router C.
Gateway Address
As previously discussed, the term gateway is used to describe the address of the
networking device that enables the hosts in a LAN to connect to networks and hosts
outside the LAN. For example, the gateway address for all hosts in LAN A will be
10.10.20.250. This address is configured on the host computer, as shown in Figure
1-11. Any IP packets with a destination outside the LAN A network will be sent to
this gateway address. Note that the destination network is determined by the subnet
mask. In this case, the subnet mask is 255.255.255.0.
Network Segments
The network segment defines the networking link between two LANs. There is
a segment associated with each connection of an internetworking device (for ex-
ample, router-hub, router-switch, router-router). For example, the IP address for the
network segment connecting LAN A to the router is 10.10.20.0. All hosts connected
to this segment must contain a 10.10.20.x, because a subnet mask of 255.255.255.0
is being used. Subnet masking is fully explained in Network Essentials Chapter 6,
“TCP/IP.”
Routers use the information about the network segments to determine where to for-
ward data packets. For example, referring to Figure 1-10, the network segments that
connect to Router A include
10.10.20.0
10.10.200.0
10.10.100.0
The segment is sometimes called the subnet or NET. These terms are associated
Subnet, NET
with a network segment address, such as 10.10.20.0. In this case, the network is
called the 10.10.20.0 NET. All hosts in the 10.10.20.0 NET will have a 10.10.20.x Other terms for the
segment.
IP address. The network addresses are used when configuring the routers and defin-
ing which networks are connected to the router.
According to Figure 1-11, all the computers in LAN A must have a 10.10.20.x ad-
dress. This is defined by the 255.255.255.0 subnet mask. For example, computer
A1 in LAN A will have the assigned IP address of 10.10.20.1 and a gateway ad-
dress of 10.10.20.250. The computers in LAN B (see Figure 1-10) are located in the
Multilayer Switch
So far, the topic of network switches revolves around their Layer 2 functionalities.
Multilayer Switch Today, the scope of operations has changed for switches. Newer switch technolo-
(MLS) gies are available to help further improve the performance of computer networks.
Operates at Layer 2, but This new development started with Layer 3 switches and now there are multilayer
functions at the higher
switches. The term used to describe these switches that can operate above the OSI
layers.
Layer 2 is multilayer switches (MLS). An example is a Layer 3 switch. Layer 3
Wire Speed Routing switches still work at Layer 2, but additionally work at the network layer (Layer 3)
Data packets are of the OSI model and use IP addressing for making decisions to route a data packet
processed as fast as they in the best direction. The major difference is that the packet switching in basic rout-
arrive. ers is handled by a programmed microprocessor. The multilayer switch uses appli-
cation specific integrated circuits (ASIC) hardware to handle the packet switching.
The advantage of using hardware to handle the packet switching is a significant re-
duction in processing time (software versus hardware). In fact, the processing time
of multilayer switches can be as fast as the input data rate. This is called wire speed
routing, where the data packets are processed as fast as they are arriving. Multilayer
switches can also work at the upper layers of the OSI model. An example is a Layer
4 switch that processes data packets at the transport layer of the OSI model.
Through this evolution, the line between routers and multilayer switches is getting
more and more blurry. Routers were once considered the more intelligent device,
but this is no longer true. With new developments, the multilayer switches can do
almost everything the routers can. More importantly, most of the Layer 3 switch
configuration commands are almost identical to the ones used on the routers. Rout-
ers tend to be more expensive when it comes to cost per port. Therefore, most of the
traditional designs have a router connecting to a switch or switches to provide more
port density. This can be expensive depending on the size of the network. So, there
has been a shift toward deploying multilayer switches in the network LAN environ-
ment in place of routers. In this case, the routers and switches in Figure 1-10 then
In Layer 3 networks, routers and multilayer switches are used to interconnect the
networks and LANs, isolating broadcast domains and enabling hosts from different
LANs and networks to exchange data. Data packet delivery is achieved by hand-
ing off data to adjacent routers until the packet reaches its final destination. This
typically involves passing data packets through many routers and many networks.
An example of a Layer 3 network is shown in Figure 1-10. This example has four
LANs interconnected using three routers. The IP address for each networking de-
vice is listed.
The physical layer interface on the router provides a way to connect the router
to other networking devices on the network. For example, the FastEthernet ports Synchronous Optical
on the router are used to connect to other FastEthernet ports on other routers or Network (SONET)
switches. Gigabit and 10-gigabit Ethernet ports are also available on routers to con- Used to interconnect the
nect to other high-speed Ethernet ports (the sample network shown in Figure 1-10 router and the network
to other WANs.
includes only FastEthernet ports). Routers also contain other types of interfaces,
such as serial interfaces and Synchronous Optical Network (SONET) interfaces. WAN
These interfaces were widely used to interconnect the router and the network to Wide-area network.
other wide-area networks (WAN). For example, connection to WANs requires the
use of a serial interface or SONET interface to connect to a communications carrier,
such as Sprint, AT&T, Century Link, and so on. The data speeds for the serial com-
munication ports on routers can vary from slow (56 kbps) up to high-speed DS3
data rates (47+ Mbps), and the SONET could range from OC3 (155 Mbps), OC12
(622 Mbps), or even OC192 (9953 Mbps).
Notice that the router prompts you that the line protocol on interface FastEthernet
terminal monitor 0/0 changed state to up. These log messages are always displayed when connecting
(term mon) via the console port. However, they are suppressed when it is a remote terminal ses-
Displays log messages on sion, like Telnet or SSH. To display log messages on the remote terminal, issue the
the remote terminal.
command terminal monitor or term mon at the router prompt:
Router# term mon
The log messages can be useful when bringing up a new connection. Sometimes,
terminal no monitor they can be annoying if the router is logging too many events. To disable the log-
(term no mon) ging to the terminal, the command is terminal no monitor or term no mon. One
Disables the logging to would think the command syntax would start with no, like typical Cisco command,
the terminal. but it is not so in this case:
Router# term no mon
The command show ip interface brief (sh ip int brief) entered at the enable
show ip interface prompt (Router#) can be used to verify the status of the router interfaces. The fol-
brief (sh ip int lowing is an example:
brief)
Verifies the status of the Router# sh ip int brief
router interfaces. Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.20.250 YES manual up up
FastEthernet0/1 unassigned YES manual administratively down
down
FastEthernet0/2 unassigned YES manual administratively down
down
The output shows that the interface FastEthernet0/0 was configured with the IP ad-
dress and its status is up. Because the FastEthernet0/1 and FastEthernet0/2 were not
One concept that is worth exploring is secondary IP address. The primary address is
Secondary IP Address
the IP address that is assigned to the interface. The secondary IP address is a way to
Allows multiple Layer 3
support multiple IP addresses per router interface. Hence, it allows multiple Layer 3
networks to reside on
networks to reside on the same physical link. Secondary IP addresses can be useful
the same physical link.
when you want to add more networks without having to disturb the existing network
or to use it as a transitional network for network migration. Some people might just
want to run multiple logical subnets on one physical subnet. To add a secondary IP
address to the interface, the command is ip address [ip_address] [subnet_mask] sec-
ondary. The keyword secondary is used to specify the secondary IP address. The
secondary IP address configuration is as follows:
Router(config)# interface FastEthernet0/0
Router(config-if)# ip address 10.10.20.250 255.255.255.0
Router(config-if)# ip address 172.16.1.1 255.255.255.0 secondary
In order to configure the secondary IP address, the primary IP address must exist
first. There can be as many secondary IP addresses as needed. The secondary IP
address cannot be verified with the show int or show ip int brief command. The
results will only display the primary IP address information.
802.1Q/Trunk Port
802.1Q/Trunk Port
This design requires that the router must be configured to accept the tagged
VLANs. A Layer 3 network is then assigned to each VLAN coming to the router.
To accomplish this, subinterfaces are created under the router interface at which the
switch trunk port is terminated. The subinterface is a virtual interface, and its nota-
tion is a dot followed by the subinterface number. In the example provided, the sub-
interfaces are listed as FastEthernet0/0.1, 0.2, and 0.3. For the ease of programming,
it is recommended to keep the subinterface number the same as the VLAN ID.
Recall that the default VLAN is 1, the Sales VLAN is 2, and the Engineering VLAN
is 3. The next step is to define the VLAN tagging encapsulation. In this case, it is
dot1q, which essentially is 802.1Q. With the encapsulation, the appropriate VLAN
ID is specified. Next, the IP address is assigned creating a routed Layer 3 network
for a VLAN. The following example demonstrates how to configure a Cisco router
for a 802.1Q interVLAN routing:
Router(config)#interface FastEthernet0/0
Router(config-if)#no ip address
Router(config-if)#interface FastEthernet0/0.1
Router(config-if)#description Default VLAN
Router(config-subif)#encapsulation dot1Q 1
Router(config-subif)#ip address 172.16.10.1 255.255.255.0
Router(config-subif)#interface FastEthernet0/0.2
Router(config-subif)#description Sales VLAN
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 172.16.20.1 255.255.255.0
Router(config-subif)#interface FastEthernet0/0.3
Router(config-subif)#description Engineering VLAN
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 172.16.30.1 255.255.255.0
The communications carrier will require the serial data connection be made through
CSU/DSU a CSU/DSU (channel service unit/data service unit). The CSU/DSU provides the
Channel service unit/ hardware data interface to the carrier. This includes adding the framing information
data service unit. for maintaining the data flow, storing performance data, and providing line manage-
ment. The T1 data stream is broken into frames. Each frame consists of 24 voice
channels (8 kbps)—8 bits per channel plus one framing bit, for a total of 193 bits.
There are two framing techniques used in T1: D4 and ESF. D4, sometimes known
as SF (Super Frame), is the original framing technique. Later on, ESF (Extended
AMI Super Frame) was introduced as an improvement in data performance over D4
Alternate mark framing.
inversion. A fundamental
line coding scheme Along with Framing, T1 requires line coding. The data connection to the commu-
developed for nications carrier requires that the proper data encoding format be selected for the
transmission over T1 CSU/DSU. Data are encoded in such a way that timing information of the binary
circuits. stream is maintained and the logical 1s and 0s can still be detected. A fundamental
B8ZS coding scheme that was developed for transmission over T1 circuits is alternate
mark inversion (AMI). The AMI code provides for alternating voltage level pulses
Bipolar 8 zero
substitution. A data
V(+) and V(-) to represent the 1s. With AMI, a long string of 0s can produce a loss
encoding format of timing and synchronization. This deficiency can be overcome by the transmis-
developed to improve sion of the appropriate start, stop, and synchronizing bits, but this comes at the
data transmission over price of adding overhead bits to the data transmission and consuming a portion
T1 circuits. of the data communication channel’s bandwidth. The bipolar 8 zero substitution
(B8ZS) data encoding format was developed to improve data transmission over T1
Minimum Ones
Density circuits. T1 circuits require that a minimum ones density level be met so that the
timing and synchronization of the data link is maintained. Maintaining a minimum
A pulse is intentionally
sent in the data stream
ones density means that a pulse is intentionally sent in the data stream even if the
even if the data being data being transmitted is a series of all 0s. Intentionally inserting the pulses in the
transmitted is a series of data stream helps maintain the timing and synchronization of the data stream. B8ZS
all 0s. is sometimes referred to as clear channel by the Telecommunication engineers.
Both framing and line coding are configured at the CSU/DSU. The configuration
HDLC
must match at both ends of the connection. The CSU/DSU could be its own unit or
High-level data link it could be built into the router serial interface. Typically, AMI signaling is paired
control, a synchronous
with D4/SF, while B8ZS signaling uses frames that are grouped into ESF.
proprietary protocol.
PPP Two other serial line protocols commonly used in wide-area networking are high-
level data link control (HDLC) and Point-to-Point Protocol (PPP). Both protocols are
Point-to-Point Protocol.
A full duplex protocol
used by routers to carry data over a serial line connection, typically over direct con-
used for serial interface nections, such as with T1. PPP is used for serial interface connections, such as that
connections such as that provided by modems. PPP is a full duplex protocol and is a subset of the HDLC
provided by modems. data encapsulation.
The following configuration example is from an older Cisco router, which has a
serial interface connecting to a CSU/DSU. The steps for setting the data encap-
sulation to HDLC and PPP on the Serial1/0 interface and configuring the serial
interface IP address are shown. The T1 encapsulation on Cisco routers is HDLC by
default, if the encapsulation is not specified. The encapsulation can be overwritten
by issuing the new encapsulation option. Finally, the interface can be enabled via
the command no shut.
Router# conf t
Router(config)# int s1/0
Router(config-if)#encap hdlc
Router(config-if)#ip address 10.10.128.1 255.255.255.0
Router# conf t
Router(config)# int s1/0
Router(config-if)#encap ppp
Router(config-if)# no shut
2w0d: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
2w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0,
changed state to up
The status of the serial interfaces can be checked using the sh ip int brief com-
mand, as demonstrated here:
Router# sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0 10.10.20.250 YES manual up up
FastEthernet0/1 unassigned YES manual administratively
down down
FastEthernet0/2 unassigned YES manual administratively
down down
Serial1/0 10.10.128.1 YES manual up up
The type of network being configured and the equipment being used to make the
direct connection determines the selection of the format for data encapsulation. For
example, Cisco routers automatically configure the serial interfaces to run HDLC,
but the Cisco routers support many data encapsulation formats. The HDLC data
encapsulation formats are implemented differently by some vendors, and there are
times when some equipment is not interoperable with other equipment even though
they both have specified the HDLC encapsulation. In that case, another encapsula-
tion format such as PPP can be used to make the direct connection.
On newer Cisco routers, there is a variety of T1 interface cards available. Most of
WIC them fall under these two types. They are either WAN interface cards (WICs) that
WAN interface cards. only provide data support or they are Voice/WAN interface cards (VWICs) that can
VWIC provide both voice and data support. These types of cards all have an integrated
Voice/WAN interface CSU/DSU, which makes it convenient for setup. In this case, a T1 connection with
cards. an RJ45 interface can be directly connected to the card. If the names WIC and
VWIC are not confusing enough, the configuration steps for these cards will cer-
service-module t1 tainly create some confusion. The configuration steps are presented next.
The router command for
configuring T1 framing, The first example shows the configuration of a router with a T1 WIC card. The T1
line coding, and the configuration, usually programmed on a CSU/DSU, is now done under a serial in-
clock source. terface. The T1 framing, line coding, and clock source are configured via command
service-module t1. In this case, ESF is selected as the framing technique, and
B8ZS is used as the line coding. The clock source line means the clock is provided
by the carrier through the T1 line. This is critical for synchronizing the T1 transmis-
sion. The timeslot defines the speed of the DS0 channel and the number of DS0
channels being used.
Router(config)#interface Serial0/1
Router(config-if)#ip address 10.10.128.1 255.255.255.0
Router(config-if)#service-module t1 timeslots 1-24 speed 64
Router(config-if)#service-module t1 framing ESF
Router(config-if)#service-module t1 linecode B8ZS
Router(config-if)#service-module t1 clock source line
Router(config-if)#encapsulation ppp
Router(config-if)#interface Serial1/0:0
Router(config-if)#ip address 10.10.128.1 255.255.255.0
Router(config-if)#encapsulation ppp
You can verify the T1 status with the command show controller T1 slot/port. This
show controller T1
command displays the T1 status with details that one would find in a CSU/DSU.
slot/port
The output result shows the T1 is up in a good clean state. So far, there are no er-
Verifies the status of the
rors for the last 24 hours:
T1 interface.
Router#show controller T1 1/0
T1 0/1/0 is up.
Applique type is Channelized T1
Cablelength is long 0db
No alarms detected.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20090408, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Line.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (195 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail
Secs
Total Data (last 24 hours)
0 Line Code Violations, 0 Path Code Violations,
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail
Secs
Asynchronous Transfer Mode (ATM) is a cell relay technique designed for voice,
data, and video traffic. It uses fixed length data packets called cells. The size of ATM
each cell is 53 bytes with 5 bytes being the ATM header. The ATM protocol was Asynchronous transfer
designed for use in high-speed multimedia networking, including operation in high- mode.
speed data transmission found in SONET’s OC-1, OC-3, OC-12, OC-48, and
OC-192.
ATM uses an 8-bit virtual path identifier (VPI) to identify the virtual circuits used to
VPI deliver cells in the ATM network. A 16-bit virtual channel identifier (VCI) is used to
Virtual path identifier. identify the connection between the two ATM stations. The VPI and VCI numbers
VCI are provided by the telco. Together, the numbers are used to create an ATM PVC
Virtual channel (permanent virtual circuit) through the ATM cloud, as demonstrated in Figure 1-13.
identifier. The VPI/VCI numbers (1/33) shown in Figure 1-13 are for the ATM PVC interface.
Router A connects to the ATM cloud via an ATM physical interface on the router.
Router B also connects to the ATM cloud via an ATM physical interface on the
router. In this example, the name for the physical interface on Router A is ATM 4/0.
This is comparable to the E0 name for the router’s Ethernet0 interface.
Router A VPI/VCI
1/33
ATM
cloud
1/33
Router B
The first line, Interface ATM 4/0, identifies the physical interface being configured
(in this case, ATM interface 4). The second line, description net atm (1 2 3 4 5 6
7 8 9), is a description of the ATM connection. The name of the connection is net;
it is an ATM connection, and the telco circuit number is 1 2 3 4 5 6 7 8 9. The third
line, no ip address, indicates that no IP address is specified for the ATM inter-
face. The physical interface on an ATM connection is not assigned an IP address.
The two commands atm scrambling cell-payload and atm framing cbitplcp are
entries required to make the connection to the telco interface. Telco specifies the
format for these commands. The entry no atm ilmi-keepalive is used to disable the
generation of keepalive messages.
The next group of commands is used to configure the router’s subinterface:
interface ATM4/0.33 point-to-point
description PVC to CityB (1 2 3 4 5 4 3 2 1)
ip address 192.168.23.1 255.255.255.0
pvc netB 1/33
vbr-nrt 3000 3000 1 broadcast encapsulation aal5snap
The entry interface ATM 4/0.33 point-to-point indicates that the VCI number for
the subinterface is 33 and it is on the ATM 4 physical interface. It also indicates
that this is a point-to-point connection. The second line is for the description of the
subinterface. It indicates that this is a PVC for connecting to CityB’s network, and
the telco circuit number is 1 2 3 4 5 4 3 2 1. The third line specifies the IP address
for the subinterface.
The entry pvc netB 1/33 creates a PVC with a VPI of 1 and a VCI of 33. The entry
vdr-nrt 3000 3000 1 is used to configure the peak, average, and burst options for
voice traffic over the PVC. This parameter is typically specified by telco. The out-
put pcr (peak cell rate) is 3,000 kbps and the output scr (sustained cell rate) is 3000
kbps. The 1 indicates an output mbs (maximum burst size) of 1.
The entry broadcast enables broadcasts to be forwarded across the ATM PVC. The
entry encapsulation aal5snap indicates that the ATM adaptation layer 5 is to be
used to prepare the data for transmission over ATM. AAL5 encapsulation is typi-
cally specified to transport TCP/IP data traffic over ATM.
To display the ATM interfaces, enter the show atm vc router command, as demon-
strated in the following ouput:
router#sh atm vc
Interface VCD/ Peak Avg/Min Burst
Name VPI VCI Type Encaps SC Kbps Kbps Cells Sts
2/0.32 1 1 32 PVC SNAP UBR 100000 UP
2/0.33 2 1 33 PVC SNAP UBR 3000 UP
2/0.34 6 1 34 PVC SNAP CBR 5000 DOWN
The last command examined is used to display information on the interface. The
command used is show controller atm slot/port. In this case, the information on
the atm1/0 interface is displayed. Part of the display for the atm1/0 interface is
listed:
router#sh controller atm1/0
Interface ATM1/0 is up
Hardware is ENHANCED ATM PA Plus - OC3 (155000Kbps)
Framer is PMC PM5346 S/UNI-155-LITE, SAR is LSI ATMIZER II
Firmware rev: X102, Framer rev: 0, ATMIZER II rev: 4
idb=0x638A43E0, ds=0x638AC000, vc=0x638F76E0
slot 1, unit 1, subunit 0, fci_type 0x03A9, ticks 226930
2400 rx buffers: size=512, encap=64, trailer=28, magic=4
Curr Stats:
VCC count: current=6, peak=6
AAL2 VCC count: 0
AAL2 TX no buffer count: 0
SUMMARY
The fundamentals of configuring and managing a campus network have been pre-
sented in this chapter. This has been an overview of the campus network infrastruc-
ture, and you should understand that each of the topics presented in this chapter
could easily be expanded to fill an entire textbook(s). What you should understand
from this reading is that configuring and managing a campus network is a major
task. You should appreciate the fact that configuring and managing a campus type