Configure IPv4 Static and Default Routes - ILM

Download as pdf or txt
Download as pdf or txt
You are on page 1of 7

Lab - Configure IPv4 Static and Default Routes

Topology

Addressing Table
Device Interface IP Address / Prefix

R1 G0/0/0 172.16.1.1 /24

R1
G0/0/1 192.168.1.1 /24

R1
Loopback1 10.1.0.1 /24

R1
Loopback2 209.165.200.225 /27
R2 G0/0/0 172.16.1.2 /24

R2
G0/0/1 192.168.1.2 /24

R2
Loopback1 10.2.0.1 /24

R2
Loopback2 209.165.200.193 /27

Objectives
Part 1: Build the Network and Configure Basic Device Settings
Part 2: Configure and verify IP addressing on R1 and R2
Part 3: Configure and verify static and default routing for IPv4 on R1 and R2

Background / Scenario
Static and Default routing are the simplest forms of network routing and configured manually. They are fixed,
meaning that they do not change dynamically to meet changing network conditions. They are either valid and

 2013 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 7 www.netacad.com
Lab - Configure IPv4 Static and Default Routes

made available to the routing table or invalid and not made available to the routing table. Static routes have
an administrative distance of one by default. However, static and default routes can be configured with an
administrator-defined administrative distance. This capability allows the administrator to put the static or
default route in reserve, and only make it available to the routing table when routes with lower administrative
distances (usually generated by dynamic routing protocols) are no longer valid.
Note: In this lab you will configure static, default, and floating default routes for both IPv4
which may not reflect networking best practices.
Note: The routers used with CCNA hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4
(universalk9 image). The switches used in the labs are Cisco Catalyst 2960s with Cisco IOS Release 15.2(2)
(lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model
and Cisco IOS version, the commands available and the output produced might vary from what is shown in
the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.
Note: Ensure that the routers and switches have been erased and have no startup configurations. If you are
unsure contact your instructor.
Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices

Required Resources
 2 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
 2 Switches (Cisco 2960 with Cisco IOS Release 15.2(2) lanbasek9 image or comparable)
 1 PC (Windows with a terminal emulation program, such as Tera Term)

 Console cables to configure the Cisco IOS devices via the console ports
 Ethernet cables as shown in the topology

Instructions

Part 1: Build the Network and Configure Basic Device Settings


In Part 1, you will set up the network topology and configure basic settings on the PC hosts and switches.

Step 1: Cable the network as shown in the topology.


Attach the devices as shown in the topology diagram, and cable as necessary.

Step 2: Configure basic settings for each router.


a. Assign a device name to the router.
Open configuration window

router(config)# hostname R1

router(config)# hostname R2
b. Disable DNS lookup to prevent the router from attempting to translate incorrectly entered commands as
though they were host names.
R1(config)# no ip domain lookup

R2(config)# no ip domain lookup


c. Assign class as the privileged EXEC encrypted password.
R1(config)# enable secret class

 2013 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 7 www.netacad.com
Lab - Configure IPv4 Static and Default Routes

R2(config)# enable secret class


d. Assign cisco as the console password and enable login.
R1(config)# line console 0
R1(config-line)# password cisco
R1(config-line)# login

R2(config)# line console 0


R2(config-line)# password cisco
R2(config-line)# login
e. Assign cisco as the VTY password and enable login.
R1(config)# line vty 0 4
R1(config-line)# password cisco
R1(config-line)# login

R2(config)# line vty 0 4


R2(config-line)# password cisco
R2(config-line)# login
f. Encrypt the plaintext passwords.
R1(config)# service password-encryption
R2(config)# service password-encryption
g. Create a banner that warns anyone accessing the device that unauthorized access is prohibited.
R1(config)# banner motd $ Authorized Users Only! $

R2(config)# banner motd $ Authorized Users Only! $


h. Save the running configuration to the startup configuration file.
R1(config)# exit
R1# copy running-config startup-config

R2(config)# exit
R2# copy running-config startup-config
Close configuration window

Step 3: Configure basic settings for each switch.


Open configuration window

a. Assign a device name to the switch.


switch(config)# hostname S1

switch(config)# hostname S2
b. Disable DNS lookup to prevent the router from attempting to translate incorrectly entered commands as
though they were host names.
S1(config)# no ip domain-lookup

S2(config)# no ip domain-lookup
c. Assign class as the privileged EXEC encrypted password.

 2013 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 7 www.netacad.com
Lab - Configure IPv4 Static and Default Routes

S1(config)# enable secret class

S2(config)# enable secret class


d. Assign cisco as the console password and enable login.
S1(config)# line console 0
S1(config-line)# password cisco
S1(config-line)# login

S2(config)# line console 0


S2(config-line)# password cisco
S2(config-line)# login
e. Assign cisco as the VTY password and enable login.
S1(config)# line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login

S2(config)# line vty 0 15


S2(config-line)# password cisco
S2(config-line)# login
f. Encrypt the plaintext passwords.
S1(config)# service password-encryption

S2(config)# service password-encryption


g. Create a banner that warns anyone accessing the device that unauthorized access is prohibited.
S1(config)# banner motd $ Authorized Users Only! $

S2(config)# banner motd $ Authorized Users Only! $


h. Shutdown all interfaces that will not be used.
S1(config)# interface range f0/1-3, f0/6-24, g0/1-2
S1(config-if-range)# shutdown

S2(config)# interface range f0/1-3, f0/6-24, g0/1-2


S2(config-if-range)# shutdown
i. Save the running configuration to the startup configuration file.
S1(config-if-range)# exit
S1# copy running-config startup-config

S2(config-if-range)# exit
S2# copy running-config startup-config
Question:

Issuing the command show cdp neighbors at this point on R1 or R2 results in an empty list. Explain.
Type your answers here.
Because the router interfaces are shut down by default.

 2013 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 7 www.netacad.com
Lab - Configure IPv4 Static and Default Routes

Close configuration window

Part 2: Configure and verify IPv4 addressing on R1 and R2


In Part 2, you will configure and verify the IPv4 addresses on R1 and R2. Use the table above for the
information necessary to complete this part.

Step 1: Configure IP addresses for both routers.


Open configuration window

a. Configure the IP address for all the interfaces according to the Addressing Table.
R1(config)# interface g0/0/0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface g0/0/1
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface lo1
R1(config-if)# ip address 10.1.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface lo2
R1(config-if)# ip address 209.165.200.225 255.255.255.224
R1(config-if)# no shutdown

R2(config)# interface g0/0/0


R2(config-if)# ip address 172.16.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface g0/0/1
R2(config-if)# ip address 192.168.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface lo1
R2(config-if)# ip address 10.2.0.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface lo2
R2(config-if)# ip address 209.165.200.193 255.255.255.224
R2(config-if)# no shutdown

Step 2: Verify addressing


a. Issue the command to verify IPv4 assignments to the interfaces.
R1# show ip interface brief

R2# show ip interface brie

Step 3: Save your configuration


Save the running configuration to the startup configuration file on both routers.
R1# copy running-config startup-config

R2# copy running-config startup-config


Close configuration window

 2013 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 7 www.netacad.com
Lab - Configure IPv4 Static and Default Routes

Part 3: Configure and verify static and default routing for IPv4 on R1 and R2
In Part 3, you will configure static and default routing on R1 and R2 to enable full connectivity between the
routers using IPv4. Once again, the static routing being used here is not meant to represent best practice, but
to assess your ability to complete the required configurations.

Step 1: On R1, configure a static route to R2’s Loopback1 network, using R2’s G0/0/1 address
as the next hop.
open configuration window

a. Use the ping command to ensure that R2’s G0/0/1 interface is reachable.
b. Configure a static route for R2’s Loopback1 network via R2’s G0/0/1 address.
R1(config)# ip route 10.2.0.0 255.255.255.0 192.168.1.2

Step 2: On R1, configure a static default route via R2’s G0/0/0 address.
a. Use the ping command to ensure that R2’s G0/0/0 interface is reachable.
b. Configure a static default route via R2’s G0/0/0 address.
R1(config)# ip route 0.0.0.0 0.0.0.0 172.16.1.2

Step 3: On R1, configure a floating static default route via R2’s G0/0/1 address.
Configure a floating static default route with an AD of 80 via R2’s G0/0/1 address.
R1(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.2 80

Step 4: On R2, configure a static default route via R1’s G0/0/0 address
a. Use the ping command to ensure that R1’s G0/0/0 interface is reachable.
b. Configure a static default route via R1’s G0/0/0 address.
R2(config)# ip route 0.0.0.0 0.0.0.0 172.16.1.1

Step 5: Verify that the routes are operational.


a. Use the show ip route command to ensure that R1’s routing table shows the static and default routes.
R1# show ip route
b.
c. On R1, issue the command traceroute 10.2.0.1. The output should show that the next hop is
192.168.1.2.
R1# traceroute 10.2.0.1
Type escape sequence to abort.
Tracing the route to 10.2.0.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.1.2 1 msec * 2 msec
d. On R1, issue the command traceroute 209.165.200.193. The output should show that the next hop is
172.16.1.2.
R1# traceroute 209.165.200.193
Type escape sequence to abort.
Tracing the route to 209.165.200.193
VRF info: (vrf in name/id, vrf out name/id)
1 172.16.1.2 2 msec * 3 msec

 2013 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 7 www.netacad.com
Lab - Configure IPv4 Static and Default Routes

e. Issue the shutdown command on R1 G0/0/0.


R1# config terminal
R1(config)# interface g0/0/0
R1(config-if)# shutdown
R1(config-if)# end
f. Demonstrate that the floating static route is working. First, issue the show ip route static command. You
should see two static routes. A default static route with an AD of 80 and a static route to the 10.2.0.0/24
network with an AD of 1.
R1# show ip route static
g.
h. Demonstrate the floating static route is working by issuing the traceroute 209.165.200.193 command.
The traceroute will show the next hop as 192.168.1.2.
R1# traceroute 209.165.200.193
i.
j. Issue the no shutdown command on R1 G0/0/0.
R1# config terminal
R1(config)# interface g0/0/0
R1(config-if)# no shutdown
R1(config-if)# end

 2013 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 7 of 7 www.netacad.com

You might also like