Clase 14. EIGRP
Clase 14. EIGRP
Clase 14. EIGRP
Algorithm
• Routing protocols use algorithms to I will use the EIGRP I will use the EIGRP
determine the best path to various DUAL algorithm to DUAL algorithm to
destinations. identify what the best identify what the best
routes are. routes are.
EIGRP Features
Frame Payload
Hello packets are used to discover & form adjacencies with neighbors.
Multicasted to:
IPv4: 224.0.0.10
IPv6: FF02::A
Hello packets are always sent unreliably. Therefore Hello packets do not require
acknowledgment.
Hello Packets
› Hello packets are sent on a regular interval. Router assumes that as long as it
is receiving Hello packets from a neighbor, the neighbor and its routes remain
viable.
› The interval depends on the interface’s bandwidth.
– Low Bandwidth = 60 seconds
› Default interval on multipoint nonbroadcast multiaccess networks (NBMA)
such as X.25, Frame Relay, and ATM interfaces with access links of T1
(1.544 Mbps) or slower.
– High bandwidth = 5 seconds
› Default interval on circuits with bandwidth greater than T1 such as
Ethernet LANs.
Hello Holdtime
› Hold time - maximum time the router should wait to receive the
next hello before declaring that neighbor as unreachable.
› Default hold time - 3 times the hello interval
› If the hold time expires:
– EIGRP declares the route as down
– DUAL searches for a new path in the topology table or by
sending out queries.
Hello Format
Update and Acknowledgement Packets
EIGRP uses
triggered
updates
› Update Packets
– Contains only the routing information needed (a change occurs)
– Sent only to those routers that require it.
– Uses reliable delivery.
› Acknowledgment (ACK) Packets
– Sent when reliable delivery is used (update, query, and reply packets).
– Unreliable unicast.
Query and Reply Packets
J. J. Garcia-Luna-Aceves
IP EIGRP Topology Table List of all routes learned from each EIGRP
Destination 1 FD / AD via each neighbor neighbor and identifies successor routes and
feasible successor routes.
IP Routing Table List of the best (successor) routes from the EIGRP
Destination 1 Best route topology table and other routing processes.
Example: EIGRP Tables
Router C’s tables:
EIGRP Administrative Distance (AD)
› EIGRP default administrative distances
Routes manually
summarized.
Routes
redistributed into
EIGRP.
Feasible Distance & Advertised Distance
In the Example , R3 will advertise to R2 its metric towards the destination.
• Advertised distance: How far the destination is away for your neighbor.
• Feasible distance: The total distance to the destination.
The best path to the destination is called the successor!
The successor will be copied from the topology table to the routing table. With EIGRP
however it’s possible to have a backup path which we call the feasible successor.
Feasible Distance & Advertised Distance
R4 R5
The path with the lowest feasible distance will be the successor (R2) so now we
answered the first question.
R1#show running-config
<Output omitted>
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0/0
ip address 192.168.10.6 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 192.168.10.10 255.255.255.252
R1#show running-config
<Output omitted>
! R2#show running-config
<Output omitted>
interface GigabitEthernet0/0 !
ip address 172.16.1.1 255.255.255.0 interface GigabitEthernet0/0
! ip address 172.16.2.1 255.255.255.0
interface Serial0/0/0 !
ip address 172.16.3.1 255.255.255.252 interface Serial0/0/0
clock rate 64000 ip address 172.16.3.2 255.255.255.252
! !
interface Serial0/0/1 interface Serial0/0/1
ip address 192.168.10.5 255.255.255.252 ip address 192.168.10.9 255.255.255.252
clock rate 64000
!
interface Serial0/1/0
ip address 209.165.200.225 255.255.255.224
router eigrp
Command
R1# conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# router ?
bgp Border Gateway Protocol (BGP)
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
ospfv3 OSPFv3
rip Routing Information Protocol (RIP)
R1(config)#router eigrp 1
R1(config-router)#
Process ID
The EIGRP router ID is used to uniquely identify each router in the EIGRP routing
domain.
RID: 2.2.2.2
RID: 1.1.1.1
RID: 3.3.3.3
All interfaces
belonging to Including the wildcard
the classful mask would only
172.16.0.0/16 advertise that subnet.
address are
enabled for For example, to
EIGRP configure only the
subnet 192.168.10.8 /30
R1(config)# router eigrp 1
R1(config-router)# network 192.168.10.0
on the S0/0/1 interface.
R1(config-router)# network 172.16.0.0
R1(config-router)#
R2(config)# router eigrp 1
R2(config-router)# network 172.16.0.0
R2(config-router)#
*Feb 28 17:51:42.543: %DUAL-5-NBRCHANGE: EIGRP-IPv4
1: Neighbor 172.16.3.1 (Serial0/0/0) is up: new
adjacency
R2(config-router)#
network Command
The local
Neighbor’s interface Seconds remaining
IPv4 receiving before declaring
address EIGRP Hello neighbor down.
packets. Reset to hold time
when Hello is
received.
R1# show ip protocols
*** IP Routing is NSF aware ***
R1#
Check the R1 Routing
Table
› EIGRP uses the following values in its composite metric to calculate the preferred path to a
network:
– Bandwidth: The lowest bandwidth between source and destination.
– Delay: The cumulative interface delay along the path
– Reliability: Worst reliability between source and destination, based on keepalives.
– Load: Worst load on a link between source and destination, based on the packet rate and the
configured bandwidth of the interface.
› Note: Although MTU is included in the routing table updates, it is not a routing metric used by
EIGRP
EIGRP Metrics
› By default:
– K1 and K3 are set to 1,
– K2, K4, and K5 are set to 0.
› The result is that only the bandwidth and delay values are used in the computation of
the default composite metric.
Examining the Metric Values
R1# show interface serial 0/0/0
Serial0/0/0 is up, line protocol is up
Hardware is GT96K Serial
Description: Link to R2
Internet address is 172.16.3.1/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
<output omitted>
› show interface command, lets you can examine the actual values
used for bandwidth, delay, reliability, and load in the computation of the
routing metric.
› Default values:
– bandwidth
– delay
Bandwidth
R1# show interface serial 0/0/0
<output omitted>
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
<output omitted>
› The bandwidth metric (1544 Kbps) is a static value used by some routing
protocols such as EIGRP and OSPF to calculate their routing metric.
– Kilobits per second (Kbps).
› The value of the bandwidth might or might not reflect the actual physical
bandwidth of the interface.
– Modifying the bandwidth value does not change the actual bandwidth of
the link.
– Should reflect actual bandwidth of the link.
Delay
R1# show interface serial 0/0/0
<output omitted>
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
<output omitted>
Delay
Media
In usec
› 100 microseconds for Fast Ethernet Gigabit Ethernet 10
interfaces. Fast Ethernet 100
Ethernet 1,000
56 Kbps 20,000
Reliability – Optional Metric
R1# show interface serial 0/0/0
<output omitted>
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
<output omitted>
› Reliability is a measure of the probability that the link will fail or how
often the link has experienced errors.
– Value between 0 and 255,
› 1 = a minimally reliable link
› 255 = 100 % reliable.
– By default EIGRP does not use reliability in its metric calculation.
Load – Optional Metric
R1# show interface serial 0/0/0
<output omitted>
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
<output omitted>
R2 192.168.1.0/24
Using the default values for K1 and K3, you can simplify this calculation
to: 7
slowest bandwidth
+ cumulative sum of all the delays
------------------------------------------------
EIGRP route metric
Example Metric Calculation
BW = 9,765
Example Metric Calculation
Delay = 2,001
Example Metric Calculation
EIGRP Load Balancing
› Routes with a metric equal to the minimum metric are installed in the
routing table.
– Referred to as “equal-cost load balancing”.
– All IP routing protocols on routers can perform equal-cost load
balancing.
› The maximum-paths maximum-path command can be used to allow
up to 16 equal-cost paths.
– Default is 4.
– Setting the maximum-path option to 1 disables load balancing.
EIGRP Equal-Cost Load Balancing
It is noted the different values for the feasible distance and advertised distance.
The lowest feasible distance is 51968 and it’s the path through R2 which makes
it the successor.
EIGRP Unequal-Cost Load Balancing
EIGRP Unequal-Cost Load Balancing
C3 and C4 have been selected as feasible successors because their advertised
distance of 51712 is lower than the feasible distance (51968) of C2.
C1(config)#router eigrp 10
C1(config-router)#variance 5
EIGRP Unequal-Cost Load Balancing