Lab1: Simple Network: 1 Topology

Download as pdf or txt
Download as pdf or txt
You are on page 1of 5

Lab1: Simple network

1 Topology
To build the topology:
• Drag and drop 6 VPCS
• Configure c3600 routers to work as switches
_ Right click on the template router c3600 and go to configuration
_ Add NM-16ESW to slot 1
_ Apply
_ NOTE: when used as a switch make sure not to use interfaces from slot 0
• Drag and drop 3 c3600 routers (used as switches)
_ Change the name to switch
_ NOTE: this allows us to implement VLAN, minimum spanning tree…
• Drag and drop 3 c7200 CISCO routers
• Connections:
_ PC to switch to router in each network
_ For each router, add 2 PA-GE (Gigabits Ethernet port adapter)
_ Connect routers together
Your network should looks like this
2 Configuration
NOTE: to copy from any console, just highlight the text and paste somewhere else. Highlighting is the
copy command.
2.1 Router1 configuration
1- Assign IPs to interfaces.
Router1#configure terminal
Router1(config)#int f0/0
Router1(config-if)#ip address 192.168.0.254 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#int g1/0
Router1(config-if)#ip address 17.0.0.1 255.255.255.252
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#int g2/0
Router1(config-if)#ip address 17.0.0.9 255.255.255.252
Router1(config-if)#no shutdown
Router1(config-if)#exit

2- Set a DHCP pool


Router1(config)#ip dhcp pool 192.168.0.1-192.168.0.200
Router1(dhcp-config)#network 192.168.0.0 255.255.255.0
Router1(dhcp-config)#default-router 192.168.0.254
Router1(dhcp-config)#end
Router1#
Router1#copy running-config startup-config

3- NAT
Router1#configure terminal
Router1(config)#interface f0/0
Router1(config-if)#ip nat inside
Router1(config-if)#exit
Router1(config)#interface g1/0
Router1(config-if)#ip nat outside
Router1(config-if)#exit
Router1(config)#int g2/0
Router1(config-if)#ip nat outside
Router1(config-if)#exit
Router1(config)#access-list 1 permit 192.168.0.0 0.0.0.255
Router1(config)#ip nat inside source list 1 interface g2/0 overload

2.2 PC1-1 and PC2-2 configuration


To configure the terminal, start the PC and open its console.
Click on ? for help.
1- Get configuration from DHCP
PC1-1> ip dhcp // to get configuration from DHCP server.
PC1-1> save // save
PC1-1> shopw ip // to show received IP.

2.3 Router2 and Router3 configuration


Configure router2 to assign IP to interfaces.
1- Configure Router2
Router2#configure terminal
Router2(config)#interface g2/0
Router2(config-if)#ip address 17.0.0.10 255.255.255.252
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#interface g1/0
Router2(config-if)#ip address 17.0.0.5 255.255.255.252
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#interface f0/0
Router2(config-if)#ip address 173.3.255.254 255.255.0.0
Router3(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#exit
Router2#copy running-config startup-config
Router2#

2- Configure Router3
Router3#configure terminal
Router3(config)#interface g1/0
Router3(config-if)#ip address 17.0.0.2 255.255.255.252
Router3(config-if)#no shutdown
Router3(config-if)#exit
Router3(config)#interface g2/0
Router3(config-if)#ip address 17.0.0.6 255.255.255.252
Router3(config-if)#no shutdown
Router3(config-if)#exit
Router3(config)#interface f0/0
Router3(config-if)#ip address 173.32.255.254 255.255.0.0
Router3(config-if)#no shutdown
Router3(config-if)#exit
Router3(config)#exit
Router3#copy running-config startup-config
Router3#

2.4 Remaining PCs


Remaining PCs will have fixed public IPs.

1- PC2-1
PC2-1> ip 173.3.0.1 255.255.0.0 173.3.255.254 (address mask gateway)
PC2-1> show ip // for verification
PC2-1> save

2- PC2-2
PC2-2> ip 173.3.0.2 255.255.0.0 173.3.255.254
PC2-2> show ip
PC2-2> save

3- PC3-1
PC3-1> ip 173.32.0.1 255.255.0.0 173.32.255.254
PC3-1> show ip
PC3-1> save

4- PC3-2
PC3-2> ip 173.32.0.2 255.255.0.0 173.32.255.254
PC3-2> show ip
PC3-2> save

2.5 Routing configuration


We need to configure routers to build routing tables using OSPF.

1- Router1
Router1#configure terminal
Router1(config)#router ospf 1
Router1(config-router)#network 17.0.0.0 0.0.0.3 area 0
Router1(config-router)#network 17.0.0.8 0.0.0.3 area 0
Router1(config-router)#exit

2- Router2
Router2#configure terminal
Router2(config)#router ospf 1
Router2(config-router)#network 17.0.0.8 0.0.0.3 area 0
Router2(config-router)#network 17.0.0.4 0.0.0.3 area 0
Router2(config-router)#network 173.3.0.0 0.0.255.255 area 0
Router2(config-router)#exit
Router2(config)#exit

3- Router3
Router3#configure terminal
Router3(config)#router ospf 1
Router3(config-router)#network 17.0.0.4 0.0.0.3 area 0
Router3(config-router)#network 17.0.0.0 0.0.0.3 area 0
Router3(config-router)#network 173.32.0.0 0.0.255.255 area 0
Router3(config-router)#exit
Router3(config)#exit
4- Routing verification
Router1#show ip protocol
Router1#show ip ospf neighbor // Gives the neighboring networks
Router1#show ip route ospf // gives the routing table

Once done, do not forget to save the configuration


2.6 Testing
Start all nodes and wait for a moment so that all devices are up and running.
• Open PC1-1
• Ping all interfaces

3 Tracing
Now that the network is working, start all nodes.
• Right click on the link between Router1 and Router2 and select start capture.
• Monitor in Wireshark the OSPF exchange of message.
1- What is IP 224.0.0.5?
2- What is the value of TTL in hello packet? Why?
• Monitor also the link router1 router3
• Open console of PC1-1 and ping PC3-1
• Add an ICMP filter to both Wireshark
1- Check the ICMP messages
2- Check NATing
3- Check the replies
4- Why the request and the reply are on different paths?

You might also like