Ashutosh Seminar Report

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 24

A

Report of Seminar Topic

On

“Classful and Classless Routing Protocols and RIP Routing”


Submitted

In partial fulfillment

for the award of the degree of

BACHELOR OF TECHNOLOGY
In Department of

INFORMATION TECHNOLOGY ENGINEERING

Seminar in charge: - Submitted by:-


Mr. Vikash Kumar Ashutosh Chauhan

Lect. In C.S. & I.T. B.Tech Final year

Shekhawati Engineering College, Dundlod

Department of CS & IT

2010-2011

1
CONTENTS

S. No. Chapters Name

1. Routing
1.1 What is Routing?
1.2 Delivery semantics
1.3 Classful vs. Classless Routing
1.4 The IP Classless Command
1.5 Routing Components
1.6 Path Determination
2.
Routing Algorithms
2.1 Design Goals
2.2 Algorithm Types
2.2.1Static vs. Dynamic
2.2.2Single-path vs. Multipath
2.2.3Link-state vs. Distance vector
2.3 Routing Metrics
3. Routing Information Protocol
3.1 Introduction
3.1 Versions
3.1.1RIP version 1
3.1.2RIP version 2
3.1.3RIPng
3.2 Routing Updates
3.3 RIP Routing Metric
3.4 RIP Stability Features
3.5 RIP Timers
3.6 Packet Formats
3.6.1RIP Packet Format
3.6.2RIP 2 Packet Format

4.
2
RIP Basic Configuration
4.1 RIPv1 Configuration
4.2 RIPv2 Configuration
4.3 RIP Passive Interfaces
4.4 RIP Neighbors
4.5 Triggering RIP Updates
4.6 Troubleshooting RIP
4.7 Limitations

Chapter - 1

3
ROUTING

1.1 What Is Routing?

Routing is the act of moving information across an internetwork from a source to a


destination. Along the way, at least one intermediate node typically is encountered. Routing
is often contrasted with bridging, which might seem to accomplish precisely the same thing
to the casual observer. The primary difference between the two is that bridging occurs at
Layer 2 (the link layer) of the OSI reference model, whereas routing occurs at Layer 3 (the
network layer). This distinction provides routing and bridging with different information to
use in the process of moving information from source to destination, so the two functions
accomplish their tasks in different ways.

1.2 Delivery semantics

Routing schemes differ in their delivery semantics:

 unicast delivers a message to a single specified node;


 broadcast delivers a message to all nodes in the network;
 multicast delivers a message to a group of nodes that have expressed interest in
receiving the message;
 anycast delivers a message to any one out of a group of nodes, typically the one
nearest to the source.

The fig. 7.2.1 shows different routing schemes using nodes :

Chapter -

4
1

1.3 Classful vs. Classless Routing

Classful routing protocols do not send subnet mask information with their routing updates. A
router running a classful routing protocol will react in one of two ways when receiving a
route:

• If the router has a directly connected interface belonging to the same major network, it will
apply the same subnet mask as that interface.
• If the router does not have any interfaces belonging to the same major network, it will apply
the classful subnet mask to the route.

Belonging to same “major network” simply indicates that they belong to the same “classful”
network. For example:
• 10.3.1.0 and 10.5.5.0 belong to the same major network (10.0.0.0)
• 10.1.4.5 and 11.1.4.4 do not belong to the same major network
• 192.168.1.1 and 192.168.1.254 belong to the same major network
(192.168.1.0)
• 192.168.1.5 and 192.167.2.5 do not belong to the same major
network.
Take the following example (assume the routing protocol is classful):

If Router B sends a routing update to Router A, it will not include the subnet mask for the
10.2.0.0 network. Thus, Router A must make a decision.

If Router A has a directly connected interface that belongs to the same major network
(10.0.0.0), it will use the subnet mask of that interface for the route.
For example, if Router A has an interface on the 10.4.0.0/16 network, it will apply a subnet
mask of /16 to the 10.2.0.0 network.

5
If Router A does not have a directly connected interfacing belonging to the same major
network, it will apply the classful subnet mask of /8. This can obviously cause routing
difficulties.

Chapter - 1

When using classful routing protocols, the subnet mask must remain consistent throughout
your entire network.

Classless routing protocols do send the subnet mask with their updates. Thus, Variable
Length Subnet Masks (VLSMs) are allowed when using classless routing protocols.
Examples of classful routing protocols include RIPv1 and IGRP.
Examples of classless routing protocols include RIPv2, EIGRP, OSPF, and
IS-IS.

1.4 The IP Classless Command

The preceding section described how classful and classless protocols differ when sending
routing updates. Additionally, the router itself can operate either “classfully” or “classlessly”
when actually routing data.

When a “classful” router has an interface connected to a major network, it believes it knows
all routes connected to that major network.

For example, a router may have an interface attached to the 10.1.5.0/24 network. It may also
have routes from a routing protocol, also for the 10.x.x.x network.

However, if the classful router receives a packet destined for a 10.x.x.x subnet that is not in
the routing table, it will drop that packet, even if there is a default route.

Again, a classful router believes it knows all possible destinations in a major network.

To configure your router in “classful” mode:

Router(config)# no ip classless

To configure your router in “classless” mode (this is default in IOS 12.0 and greater):

Router(config)# ip classless

1.5 Routing Components

6
Routing involves two basic activities: determining optimal routing paths and transporting
information groups (typically called packets) through an internetwork. In the context of the

Chapter - 1

routing process, the latter of these is referred to as packet switching. Although packet
switching is relatively straightforward, path determination can be very complex.

1.6 Path Determination

Routing protocols use metrics to evaluate what path will be the best for a packet to travel. A
metric is a standard of measurement, such as path bandwidth, that is used by routing
algorithms to determine the optimal path to a destination. To aid the process of path
determination, routing algorithms initialize and maintain routing tables, which contain route
information. Route information varies depending on the routing algorithm used. Routing
algorithms fill routing tables with a variety of information. Destination/next hop associations
tell a router that a particular destination can be reached optimally by sending the packet to a
particular router representing the “next hop” on the way to the final destination. When a
router receives an incoming packet, it checks the destination address and attempts to associate
this address with a next hop. Figure 1.6.1 depicts a sample destination/next hop routing table.

Fig. 1.6.1 Destination/Next Hop Associations Determine the Data’s Optimal Path

Routing tables also can contain other information, such as data about the desirability of a
path. Routers compare metrics to determine optimal routes, and these metrics differ
depending on the design of the routing algorithm used. Routers communicate with one
another and maintain their routing tables through the transmission of a variety of messages.
The routing update message is one such message that generally consists of all or a portion of
a routing table. By analyzing routing updates from all other routers, a router can build a

7
detailed picture of network topology. A link-state advertisement, another example of a
message sent between routers, informs other routers of the state of the sender’s links.

Chapter - 1

Switching algorithms is relatively simple; it is the same for most routing protocols. In most
cases, a host determines that it must send a packet to another host. Having acquired a router’s
address by some means, the source host sends a packet addressed specifically to a router’s
physical (Media Access Control [MAC]-layer) address, this time with the protocol (network
layer) address of the destination host. As it examines the packet’s destination protocol
address, the router determines that it either knows or does not know how to forward the
packet to the next hop. If the router does not know how to forward the packet, it typically
drops the packet. If the router knows how to forward the packet, however, it changes the
destination physical address to that of the next hop and transmits the packet. The next hop
may be the ultimate destination host. If not, the next hop is usually another router, which
executes the same switching decision process. As the packet moves through the
internetwork, its physical address changes, but its protocol address remains constant, as
illustrated in Figure 1.6.2

Figure 1.6.2 Numerous Routers May Come into Play During the Switching Process

8
Chapter - 2

ROUTING ALGORITHMS

Routing algorithms can be differentiated based on several key characteristics. First, the
particular goals of the algorithm designer affect the operation of the resulting routing
protocol. Second, various types of routing algorithms exist, and each algorithm has a different
impact on network and router resources. Finally, routing algorithms use a variety of metrics
that affect calculation of optimal routes.

2.1 Design Goals

Routing algorithms often have one or more of the following design goals:

• Optimality

• Simplicity and low overhead

• Robustness and stability

• Rapid convergence

• Flexibility

Optimality refers to the capability of the routing algorithm to select the best route, which
depends on the metrics and metric weightings used to make the calculation.

Routing algorithms also are designed to be as simple as possible. In other words, the routing
algorithm must offer its functionality efficiently, with a minimum of software and utilization
overhead. Efficiency is particularly important when the software implementing the routing
algorithm must run on a computer with limited physical resources.

Routing algorithms must be robust, which means that they should perform correctly in the
face of unusual or unforeseen circumstances, such as hardware failures, high load conditions,
and incorrect implementations. Because routers are located at network junction points, they

9
can cause considerable problems when they fail. The best routing algorithms are often those
that have withstood the test of time and that have proven stable under a variety of network
conditions.

Chapter - 2

In addition, routing algorithms must converge rapidly. Convergence is the process of


agreement, by all routers, on optimal routes. When a network event causes routes to either go
down or become available, routers distribute routing update messages that permeate
networks, stimulating recalculation of optimal routes and eventually causing all routers to
agree on these routes. Routing algorithms that converge slowly can cause routing loops or
network outages.

Routing algorithms should also be flexible, which means that they should quickly and
accurately adapt to a variety of network circumstances.

2.2 Algorithm Types

Routing algorithms can be classified by type. Key differentiators include these:

• Static versus Dynamic


• Single-path versus Multipath
• Link-state versus Distance vector

2.2.1 Static Versus Dynamic

Static routing algorithms are hardly algorithms at all, but are table mappings established by
the network administrator before the beginning of routing. These mappings do not change
unless the network administrator alters them. Algorithms that use static routes are simple to
design and work well in environments where network traffic is relatively predictable and
where network design is relatively simple.

Because static routing systems cannot react to network changes, they generally are
considered unsuitable for today’s large, constantly changing networks. Most of the dominant
routing algorithms today are dynamic routing algorithms, which adjust to changing network
circumstances by analyzing incoming routing update messages. If the message indicates that
a network change has occurred, the routing software recalculates routes and sends out new
routing update messages. These messages permeate the network, stimulating routers to rerun
their algorithms and change their routing tables accordingly.

10
Dynamic routing algorithms can be supplemented with static routes where appropriate. A
router of last resort (a router to which all unroutable packets are sent).

Chapter - 2

2.2.2 Single-Path Versus Multipath

Some sophisticated routing protocols support multiple paths to the same destination. Unlike
single-path algorithms, these multipath algorithms permit traffic multiplexing over multiple
lines. The advantages of multipath algorithms are obvious: They can provide substantially
better throughput and reliability. This is generally called load sharing.

2.2.3 Link-State Versus Distance Vector

Link-state algorithms (also known as shortest path first algorithms) flood routing information
to all nodes in the internetwork. Each router, however, sends only the portion of the routing
table that describes the state of its own links. In link-state algorithms, each router builds a
picture of the entire network in its routing tables. Distance vector algorithms (also known as
Bellman-Ford algorithms) call for each router to send all or some portion of its routing table,
but only to its neighbors. In essence, link-state algorithms send small updates everywhere,
while distance vector algorithms send larger updates only to neighboring routers. Distance
vector algorithms know only about their neighbors.

Because they converge more quickly, link-state algorithms are somewhat less prone to
routing loops than distance vector algorithms. On the other hand, link-state algorithms require
more CPU power and memory than distance vector algorithms. Link-state algorithms,
therefore, can be more expensive to implement and support. Link-state protocols are
generally more scalable than distance vector protocols.

2.3 Routing Metrics

Routing tables contain information used by switching software to select the best route.
Routing algorithms have used many different metrics to determine the best route.
Sophisticated routing algorithms can base route selection on multiple metrics, combining
them in a single (hybrid) metric.

All the following metrics have been used:

11
• Path length
• Reliability
• Delay
• Bandwidth

Chapter - 3

ROUTING INFORMATION PROTOCOL

3.1 Introduction

The Routing Information Protocol (RIP) is a standardized Distance Vector protocol,


designed for use on smaller networks. RIP was one of the first true Distance Vector routing
protocol, and is supported on a wide variety of systems.

RIP adheres to the following Distance Vector characteristics:

 RIP sends out periodic routing updates (every 30 seconds)

 RIP sends out the full routing table every periodic update

 RIP uses a form of distance as its metric (in this case, hopcount)

 RIP uses the Bellman-Ford Distance Vector algorithm to determine the best “path” to
a particular destination.

Other characteristics of RIP include :

 RIP supports IP and IPx routing.

 RIP utilizes UDP port 520

 RIP routs have an administrative distance of 120.

 RIP has a maximum hopcount of 15 hops.

12
Any network that is 16 hops away or more is considered unreachable to RIP, thus the
maximum diameter of the network is 15 hops. A metric of 16 hops in RIP is considered as a
poison route or infinity metric.

If multiple paths exist to a particular destination, RIP will load balance between those paths
(by default upto 4) only if the metric is equal. RIP uses a round-robin system of load-
balancing between equal metric routes, which can lead to pinhole congestion.

3.2 Versions

There are three versions of the Routing Information Protocol: RIPv1, RIPv2, and RIPng.

Chapter - 3

3.2.1 RIP version 1

The original specification of RIP, defined in RFC 1058,[3] uses classful routing. The periodic
routing updates do not carry subnet information, lacking support for variable length subnet
masks (VLSM). This limitation makes it impossible to have different-sized subnets inside of
the same network class. In other words, all subnets in a network class must have the same
size. There is also no support for router authentication, making RIP vulnerable to various
attacks. The RIP version 1 works when there is only 16 hop counts (0-15).If there are more
than 16 hops between two routers it fails to send data packets to the destination address.

3.2.2 RIP version 2

Due to the deficiencies of the original RIP specification, RIP version 2 (RIPv2) was
developed in 1993[4] and last standardized in 1998.[5] It included the ability to carry subnet
information, thus supporting Classless Inter-Domain Routing (CIDR). To maintain backward
compatibility, the hop count limit of 15 remained. RIPv2 has facilities to fully interoperate
with the earlier specification if all Must Be Zero protocol fields in the RIPv1 messages are
properly specified. In addition, a compatibility switch feature[5] allows fine-grained
interoperability adjustments.

In an effort to avoid unnecessary load on hosts that do not participate in routing, RIPv2
multicasts the entire routing table to all adjacent routers at the address 224.0.0.9, as opposed
to RIPv1 which uses broadcast. Unicast addressing is still allowed for special applications.

13
Route tags were also added in RIP version 2. This functionality allows for routes to be
distinguished from internal routes to external redistributed routes from EGP protocols.

3.2.3 RIPng

RIPng (RIP next generation), defined in RFC 2080,[8] is an extension of RIPv2 for support of
IPv6, the next generation Internet Protocol.

The main differences between RIPv2 and RIPng are:

 Support of IPv6 networking.

Chapter - 3

 While RIPv2 supports RIPv1 updates authentication, RIPng does not. IPv6 routers were, at
the time, supposed to use IPsec for authentication.
 RIPv2 allows attaching arbitrary tags to routes, RIPng does not;
 RIPv2 encodes the next-hop into each route entries, RIPng requires specific encoding of the
next hop for a set of route entries.xxx

3.3 Routing Updates

RIP sends routing-update messages at regular intervals and when the network topology
changes. When a router receives a routing update that includes changes to an entry, it updates
its routing table to reflect the new route. The metric value for the path is increased by 1, and
the sender is indicated as the next hop.

RIP routers maintain only the best route (the route with the lowest metric value) to a
destination. After updating its routing table, the router immediately begins transmitting
routing updates to inform other network routers of the change. These updates are sent
independently of the regularly scheduled updates that RIP routers send.

3.4 RIP Routing Metric

RIP uses a single routing metric (hop count) to measure the distance between the source and a
destination network. Each hop in a path from source to destination is assigned a hop count
value, which is typically 1. When a router receives a routing update that contains a new or
changed destination network entry, the router adds 1 to the metric value indicated in the

14
update and enters the network in the routing table. The IP address of the sender is used as the
next hop.

3.5 RIP Stability Features

RIP prevents routing loops from continuing indefinitely by implementing a limit on the
number of hops allowed in a path from the source to a destination. The maximum number of
hops in a path is 15. If a router receives a routing update that contains a new or changed
entry, and if increasing the metric value by 1 causes the metric to be infinity (that is, 16), the
network destination is considered unreachable. The downside of this stability feature is that it
limits the maximum diameter of a RIP network to less than 16 hops.

RIP includes a number of other stability features that are common to many routing protocols.
These features are designed to provide stability despite potentially rapid changes in a
network’s

Chapter - 3

topology. For example, RIP implements the split horizon and holddown mechanisms to
prevent incorrect routing information from being propagated.

3.6 RIP Timers

RIP uses numerous timers to regulate its performance. These include a routing-update timer,
a route-timeout timer, and a route-flush timer. The routing-update timer clocks the interval
between periodic routing updates. Generally, it is set to 30 seconds, with a small random
amount of time added whenever the timer is reset. This is done to help prevent congestion,
which could result from all routers simultaneously attempting to update their neighbors. Each
routing table entry has a route-timeout timer associated with it. When the route-timeout timer
expires, the route is marked invalid but is retained in the table until the route-flush timer
expires.

3.7 Packet Formats

3.7.1 RIP Packet Format

An IP RIP Packet Consists of Nine Fields. Figure 9.7.1 illustrates the IP RIP packet format.

15
The following descriptions summarize the IP RIP packet format fields are:

 Command - Indicates whether the packet is a request or a response. The request asks
that a router send all or part of its routing table. The response can be an unsolicited
regular routing update or a reply to a request. Responses contain routing table entries.
Multiple RIP packets are used to convey information from large routing tables.
 Version number - Specifies the RIP version used. This field can signal different
potentially incompatible versions.
 Zero - This field is not actually used by RFC 1058 RIP; it was added solely to
provide backward compatibility with prestandard varieties of RIP. Its name comes
from its defaulted value: zero.

Chapter - 3

 Address-family identifier (AFI) - Specifies the address family used. RIP is designed
to carry routing information for several different protocols. Each entry has an address-
family identifier to indicate the type of address being specified. The AFI for IP is 2.
 Address - Specifies the IP address for the entry.
 Metric - Indicates how many internetwork hops (routers) have been traversed in the
trip to the destination. This value is between 1 and 15 for a valid route, or 16 for an
unreachable route.

Note : Up to 25 occurrences of the AFI, Address, and Metric fields are permitted in a single
IP RIP packet. (Up to 25 destinations can be listed in a single RIP packet.)

3.7.2 RIP 2 Packet Format

The RIP 2 specification (described in RFC 1723) allows more information to be included in
RIP packets and provides a simple authentication mechanism that is not supported by RIP.
An IP RIP 2 Packet Consists of Fields Similar to Those of an IP RIP Packet.

16
Figure 3.7.2 shows the IP RIP 2 packet format.

The following descriptions summarize the IP RIP 2 packet format fields are:

 Command - Indicates whether the packet is a request or a response. The request asks
that a router send all or a part of its routing table. The response can be an unsolicited
regular routing update or a reply to a request. Responses contain routing table entries.
Multiple RIP packets are used to convey information from large routing tables.
 Version - Specifies the RIP version used. In a RIP packet implementing any of the
RIP 2 fields or using authentication, this value is set to 2.
 Unused - Has a value set to zero.
 Address-family identifier (AFI) - Specifies the address family used. RIPv2’s AFI
field functions identically to RFC 1058 RIP’s AFI field, with one exception: If the
AFI for the

Chapter - 3

first entry in the message is 0xFFFF, the remainder of the entry contains
authentication information. Currently, the only authentication type is simple
password.

 Route tag - Provides a method for distinguishing between internal routes (learned by
RIP) and external routes (learned from other protocols).
 IP address - Specifies the IP address for the entry.
 Subnet mask - Contains the subnet mask for the entry. If this field is zero, no subnet
mask has been specified for the entry.
 Next hop - Indicates the IP address of the next hop to which packets for the entry
should be forwarded.
 Metric - Indicates how many internetwork hops (routers) have been traversed in the
trip to the destination. This value is between 1 and 15 for a valid route, or 16 for an
unreachable route.

17
Note : Up to 25 occurrences of the AFI, Address, and Metric fields are permitted in a single
IP RIP packet. That is, up to 25 routing table entries can be listed in a single RIP packet. If
the AFI specifies an authenticated message, only 24 routing table entries can be specified.

Given that individual table entries aren’t fragmented into multiple packets, RIP does not need
a mechanism to resequence datagrams bearing routing table updates from neighboring
routers.

Chapter - 4

RIP BASIC CONFIGURATION

4.1 RIPv1 Configuration

To configure Router A, we would type:

18
Router(config)# router rip
Router(config-router)# network 172.16.0.0
Router(config-router)# network 172.17.0.0

The first command, router rip, enables the RIP process.

The network statement tells RIP which networks you wish to advertise to other RIP routers.
We simply list the networks that are directly connected to our router. Notice that we specify
the networks at their classful boundaries, and we do not specify a subnet mask.

To configure Router B:

Router(config)# router rip


Router(config-router)# network 172.17.0.0
Router(config-router)# network 172.18.0.0

The routing table on Router A will look like:


RouterA# show ip route
<eliminated irrelevant header>
Gateway of last resort is not set
C 172.16.0.0 is directly connected, Ethernet0
C 172.17.0.0 is directly connected, Serial0
R 172.18.0.0 [120/1] via 172.17.1.2, 00:00:00, Serial0
The routing table on Router B will look like:
Chapter - 4

RouterA# show ip route

<eliminated irrelevant header>

Gateway of last resort is not set

C 172.17.0.0 is directly connected, Ethernet0


C 172.18.0.0 is directly connected, Serial0
R 172.16.0.0 [120/1] via 172.17.1.1, 00:00:00, Serial0

4.2 RIPv2 Configuration

19
RIPv2 overcomes the limitations of RIPv1 by including the subnet mask in its routing tables.
By default, Cisco routers will use RIPv1. To change to Version 2, you must type:

Router(config)# router rip


Router(config-router)# version 2

Thus, the configuration of Router A would be:


RouterA(config)# router rip
RouterA(config-router)# version 2
RouterA(config-router)# network 10.0.0.0
RouterA(config-router)# network 192.168.123.0

However, when Router A sends a RIPv2 update to router B via Serial0, by default it will B
summarize the 10.1.0.0/16 network to 10.0.0.0/8. Again, this is because the 10.1.0.0 and
192.168.123.0 networks do not belong to the same major network. Thus, RIPv2 acts like
RIPv1 in this circumstance unless you disable auto summarization:

Chapter - 4

RouterA(config)# router rip


RouterA(config-router)# version 2
RouterA(config-router)# no auto-summary

The no auto-summary command will prevent Router A from summarizing the 10.1.0.0
network. Instead, Router A will send an update that includes both the subnetted network
(10.1.0.0) and its subnet mask (255.255.0.0).

4.3 RIP Passive Interfaces

20
It is possible to control which router interfaces will participate in the RIP process.

Consider the following scenario; Router C does not want to participate in the RIP domain.
However, it still wants to listen to updates being sent from Router B, just not send any
updates back to Router B:
RouterC(config)# router rip
RouterC(config-router)# network 10.4.0.0
RouterC(config-router)# network 10.2.0.0
RouterC(config-router)# passive-interface s0

The passive-interface command will prevent updates from being sent out of the Serial0
interface, but Router C will still receive updates on this interface.
We can configure all interfaces to be passive using the passive-interface default command,
and then individually use the no passive-interface command on the interfaces we do want
updates to be sent out:
Chapter - 4

RouterC(config)# router rip


RouterC(config-router)# network 10.4.0.0
RouterC(config-router)# network 10.2.0.0
RouterC(config-router)# passive-interface default
RouterC(config-router)# no passive-interface e0

4.4 RIP Neighbors

21
We can configure specific RIP neighbor commands, which will allow us to unicast routing
updates to those neighbors.
On Router B:
RouterB(config)# router rip
RouterB(config-router)# network 10.3.0.0
RouterB(config-router)# network 10.4.0.0
RouterB(config-router)# neighbor 10.3.5.1
RouterB(config-router)# neighbor 10.4.5.1

Router B will now unicast RIP updates to Router A and Router C.


However, Router B will still broadcast (if RIPv1) or multicast (if RIPv2) its updates, in
addition to sending unicast updates to its neighbors. In order to prevent broadcast/multicast
updates, we must also use passive interfaces:
RouterB(config)# router rip
RouterB(config-router)# passive-interface s0
RouterB(config-router)# passive-interface s1
RouterB(config-router)# neighbor 10.3.5.1

Chapter - 4

RouterB(config-router)# neighbor 10.4.5.1

The passive-interface commands prevent the updates from being broadcasted or multicasted.
The neighbor commands still allow unicast updates to those specific neighbors.

4.5 Triggering RIP Updates

22
On point-to-point interfaces, we can actually force RIP to only send routing updates if there is
a change:
RouterB(config)# interface s0.150 point-to-point
RouterB(config-if)# ip rip triggered

Again, this is applicable only to point-to-point links. We cannot configure RIP triggered
updates on an Ethernet network.

4.6 Troubleshooting RIP

Various troubleshooting commands exist for RIP.

To view the IP routing table:

RouterA# show ip route

<eliminated irrelevant header>

Gateway of last resort is not set

C 172.16.0.0 is directly connected, Ethernet0


C 172.17.0.0 is directly connected, Serial0
R 172.18.0.0 [120/1] via 172.17.1.2, 00:00:15, Serial0
R 192.168.123.0 [120/1] via 172.16.1.1, 00:00:00, Ethernet0

To view a specific route within the IP routing table:

RouterA# show ip route 172.18.0.0

Routing entry for 172.18.0.0/16


Known via “rip”, distance 120, metric 1
Last update from 172.17.1.2 on Serial 0, 00:00:15 ago

Chapter - 4

To debug RIP in real time:

Router# debug ip rip

4.7 Limitations

23
 Without using RIP-MTI, Hop count can not exceed 15, in case if it exceeds it will be
considered invalid.
 Most RIP networks are flat. There is no concept of areas or boundaries in RIP
networks.
 Variable Length Subnet Masks were not supported by RIP version 1.
 Without using RIP-MTI, RIP has slow convergence and count to infinity problems.

24

You might also like