Documentacion

Descargar como pdf o txt
Descargar como pdf o txt
Está en la página 1de 16

Situación

Una empresa necesita que se diseñe e implemente una red. La empresa tiene
oficinas en tres ciudades. Dos de las oficinas

Conexión y configuración de los routers y switches

- Conectar una red qwue sea similar al diagrama de la topologia

- Realizar las configuracións básicas de los dispositivos

Switch 1

Switch(config)#hostname S1
S1(config)#no ip domain-lookup
S1(config)#banner motd &
Enter TEXT message. End with the character '&'.
Authorized Access only team 3
&
//crear y configurar la VLAN de administración
Switch 2

Switch>en
Switch#conf t
Switch(config)#hostname S2
S2(config)#no ip domain-lookup
S2(config)#banner motd &
Enter TEXT message. End with the character '&'.
Authorized Access only team 3
&

Switch 3
Switch>en
Switch#conf t
Switch(config)#hostname S3
S3(config)#no ip domain-lookup
S3(config)#banner motd $
Enter TEXT message. End with the character '$'.
Authorized access only team 3 $

Fase 3: Configurar STP


- Configurar S1 para que siempre sea raíz

S1(config)#spanning-tree vlan 10,12,13 root primary


ó
S1(config)#spanning-tree vlan 10 priority 24576
S1(config)#spanning-tree vlan 12 priority 24576
S1(config)#spanning-tree vlan 13 priority 24576

Fase 4: Configuración de VTP y VLAN


- Configurar VTP con la siguiente información
Switch 1.- Servidor
S1(config)#vtp mode server
S1(config)#vtp domain lab1
S1(config)#vtp password cisco
S1(config)#end

S1(config)#vlan 10
S1(config-vlan)#name Recursos_humanos
S1(config-vlan)#exit
S1(config)#interface vlan 10
S1(config-if)#ip address 172.16.0.1 255.255.254.0
S1(config-if)#no sh
S1(config-if)#exit
S1(config)#ip default-gateway 172.16.1.254
S1(config)#exit

S1(config)#vlan 12
S1(config-vlan)#name Recursoss_financieros
S1(config-vlan)#exit

S1(config)#vlan 13
S1(config-vlan)#name Ventas
S1(config-vlan)#exit

S1(config)#vlan 20
S1(config-vlan)#name Servidores
S1(config-vlan)#exit

S1(config)#vlan 30
S1(config-vlan)#name Usuarios_inalambricos
S1(config-vlan)#exit

Switch 2.- Cliente


S2(config)#vtp mode client
S2(config)#vtp domain lab1
S2(config)#vtp password cisco
S2(config)#end

S2(config)#interface vlan 20
S2(config-if)#ip address 172.16.4.1 255.255.255.240
S2(config-if)#no shutdown
S2(config-if)#exit
S2(config)#ip default-gateway 172.16.4.14

Switch 3.- Cliente


S3(config)#vtp mode
S3(config)#vtp mode client
S3(config)#vtp domain lab1
S3(config)#vtp password cisco
S3(config)#end

S3(config)#vlan 30
S3(config-vlan)#name USUARIOS_INALAMBRICOS
S3(config-vlan)#exit
S3(config)#interface vlan 30
S3(config-if)#ip add 172.16.3.129 255.255.255.128
S3(config-if)#no shutdown
S3(config-if)#exit
S3(config)#ip deFault-gateway 172.16.3.254

Fase 5: Consideraciones para enlaces troncales


-Switch 1:
Troncal entre S1 y R1 permita trafico para las VLAN 10,12 y 13
S1#conf t
S1(config)#interface fastEthernet 0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk allowed vlan 10,12,13
S1(config-if)#end

Troncal entre S1 y S2 permita trafico para la VLAN 12

S1#conf t
S1(config)#interface fastEthernet 0/5
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk allowed vlan 12
S1(config-if)#end

Troncal entre S1 y S3 permita trafico para las VLAN 13

S1#conf t
S1(config)#interface fastEthernet 0/6
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk allowed vlan 13
S1(config-if)#end
Switch 2:
Troncal entre S2 y R2 permita trafico para las VLAN 12 y 20

S2(config)#interface fastEthernet 0/1


S2(config-if)#switchport mode trunk
S2(config-if)#switchport trunk allowed vlan 12,20
S2(config-if)#end

Troncal entre S2 y S1 permita trafico para las VLAN 12 y 20

S2(config)#interface fastEthernet 0/5


S2(config-if)#switchport mode trunk
S2(config-if)#switchport trunk allowed vlan 12
S2(config-if)#end

Switch 3:

Troncal entre S3 y R3 permita trafico para las VLAN 13 y 30

S3(config)#interface fastEthernet 0/1


S3(config-if)#switchport mode trunk
S3(config-if)#switchport trunk allowed vlan 13,30
S3(config-if)#end

Troncal entre S3 y S1 permita trafico para las VLAN 13 y 30

S3(config)#interface fastEthernet 0/6


S3(config-if)#switchport mode trunk
S3(config-if)#switchport trunk allowed vlan 13
S3(config-if)#end
Fase 6.- Configuracion de enrutamiento.
El enlace WAN entre el R2 y el ISP no participa en el proceso del protocolo de
enrutamiento.

Asignacion de direcciones a los routers:

Router 1:
Router#conf t
Router(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#banner motd &
Enter TEXT message. End with the character '&'.
Authorized Access only team 3
&

R1(config)#interface fastEthernet 0/1


R1(config-if)#ip address 172.16.1.254 255.255.254.0
R1(config-if)#no sh

R1(config)#interface serial 0/0/0


R1(config-if)#ip address 172.16.4.17 255.255.255.252
R1(config-if)#no sh
R1(config-if)#end

Router 2:
Router#conf t
Router(config)#hostname R2
R2(config)#no ip domain-lookup
R2(config)#bAnner motd &
Enter TEXT message. End with the character '&'.
Authorized Access only team 3
&
R2(config)#

R2(config)#interface serial 0/0/0


R2(config-if)#ip address 172.16.4.18 255.255.255.252
R2(config-if)#no sh
R2(config-if)#clock rate 64000
R2(config-if)#
R2(config-if)#exit

R2(config)#interface fastEthernet 0/1


R2(config-if)#ip address 172.16.4.14 255.255.255.240
R2(config-if)#no sh
R2(config-if)#end

R2(config)#int serial 0/2/0


R2(config-if)#ip address 200.165.200.193 255.255.255.224
R2(config-if)#clock rate 64000
R2(config-if)#no sh
R2(config-if)#end

Router 3:
Router(config)#hostname R3
R3(config)#no ip domain-lookup
R3(config)#banner motd &
Enter TEXT message. End with the character '&'.
Authorized Access only team 3
&

R3(config)#interface fastEthernet 0/1


R3(config-if)#ip address 172.16.3.254 255.255.255.128
R3(config-if)#no sh
R3(config-if)#end

ISP:
ISP(config)#interface serial 0/0/0
ISP(config-if)#ip address 200.165.200.194 255.255.255.224
ISP(config-if)#no sh
ISP(config-if)#end

ISP(config)#interface fastEthernet 0/0


ISP(config-if)#ip address 200.165.201.1 255.255.255.224
ISP(config-if)#no sh

SP(config)#interface fastEthernet 0/1


ISP(config-if)#ip address 200.165.200.225 255.255.255.224
ISP(config-if)#no sh
Configurar el protocolo RIP v2

Creando subinterfaces en R1

R1(config)#interface fastEthernet 0/1.10


R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 172.16.1.254 255.255.254.0
R1(config-subif)#no sh
R1(config-subif)#end

R1(config)#interface fastEthernet 0/1.12


R1(config-subif)#encapsulation dot1Q 12
R1(config-subif)#ip address 172.16.2.254 255.255.255.0
R1(config-subif)#no sh
R1(config-subif)#end

R1(config)#interface fastEthernet 0/1.13


R1(config-subif)#encapsulation dot1Q 13
R1(config-subif)#ip address 172.16.3.126 255.255.255.128
R1(config-subif)#no sh
R1(config-subif)#end

Router 2

R2#conf t
R2(config)#router rip
R2(config-router)#v 2
R2(config-router)#no auto-summary
R2(config-router)#end

R2(config)#router rip
R2(config-router)#network 172.16.4.18
R2(config-router)#end

Crear subintefaz en R2 para vlan 20


R2(config)#interface fastEthernet 0/1.20
R2(config-subif)#encapsulation dot1Q 20
R2(config-subif)#ip address 172.16.4.14 255.255.255.240
R2(config-subif)#no shutdown
R2(config-subif)#end

R2(config)#interface fastEthernet 0/1.12


R2(config-subif)#encapsulation dot1Q 12
R2(config-subif)#ip address 172.16.2.254 255.255.255.0
R2(config-subif)#no sh
R2(config-subif)#end

Crear subintefaz en R3 para vlan 30

R3(config)#interface fastEthernet 0/1.30


R3(config-subif)#encapsulation dot1Q 30
R3(config-subif)#ip address 172.16.3.254 255.255.255.128
R3(config-subif)#no shutdown
R3(config-subif)#end

R3(config)#interface fastEthernet 0/1.13


R3(config-subif)#encapsulation dot1Q 13
R3(config-subif)#ip address 172.16.3.126 255.255.255.128
R3(config-subif)#no sh
R3(config-subif)#end

Configurar RIP versión 2


Router 1:
R1(config)#router rip
R1(config-router)#v 2
R1(config-router)#network 172.16.1.254
R1(config-router)#network 172.16.2.254
R1(config-router)#network 172.16.3.126
R1(config-router)#network 172.16.4.17
R1(config-router)#end
R1#
Router 2:
R2(config)#router rip
R2(config-router)#v 2
R2(config-router)#network 172.16.2.254
R2(config-router)#network 172.16.4.14
R2(config-router)#network 172.16.4.18
R2(config-router)#end
R2#

Router 3:
R3(config)#router rip
R3(config-router)#v 2
R3(config-router)#network 172.16.3.126
R3(config-router)#network 172.16.3.254
R3(config-router)#end
R3#

Fase 7: Configuracion de DHCP

Router 1
R1(config)#ip dhcp excluded-address 172.16.1.254
R1(config)#ip dhcp excluded-address 172.16.2.254
R1(config)#ip dhcp excluded-address 172.16.3.126
R1(config)#ip dhcp excluded-address 172.16.4.17
R1(config)#ip dhcp excluded-address 172.16.4.14
R1(config)#ip dhcp excluded-address 172.16.4.18
R1(config)#ip dhcp excluded-address 172.16.3.254
R1(config)#ip dhcp excluded-address 172.16.0.1
R1(config)#ip dhcp excluded-address 172.16.4.1
R1(config)#ip dhcp excluded-address 172.16.3.1

R1(config)#ip dhcp pool vlan10


R1(dhcp-config)#network 172.16.0.0 255.255.254.
R1(dhcp-config)#network 172.16.0.0 255.255.254.0
R1(dhcp-config)#default-router 172.16.0.2
R1(dhcp-config)#dns-server 172.16.4.15

R1(config)#ip dhcp pool vlan12


R1(dhcp-config)#network 172.16.2.0 255.255.255.0
R1(dhcp-config)#default-router 172.16.2.1
R1(dhcp-config)#dns-server 172.16.4.15

R1(config)#ip dhcp pool vlan13


R1(dhcp-config)#network 172.16.3.0 255.255.255.128
R1(dhcp-config)#default-router 172.16.0.2
R1(dhcp-config)#dns-server 172.16.4.15
R1(dhcp-config)#end
R1#

Router 3
R3(config)#ip dhcp eXcluded-address 172.16.1.254
R3(config)#ip dhcp eXcluded-address 172.16.2.254
R3(config)#ip dhcp eXcluded-address 172.16.3.126
R3(config)#ip dhcp eXcluded-address 172.16.4.17
R3(config)#ip dhcp eXcluded-address 172.16.0.1
R3(config)#ip dhcp eXcluded-address 172.16.4.14
R3(config)#ip dhcp eXcluded-address 172.16.4.18
R3(config)#ip dhcp eXcluded-address 172.16.4.1
R3(config)#ip dhcp eXcluded-address 172.16.3.1
R3(config)#ip dhcp eXcluded-address 172.16.3.254
R3(config)#ip dhcp eXcluded-address 172.16.3.129
R3(config)#ip dhcp pool vlan30
R3(dhcp-config)#network 172.16.3.130 255.255.255.128
R3(dhcp-config)#network 172.16.3.128 255.255.255.128
R3(dhcp-config)#default-router 172.16.3.130
R3(dhcp-config)#dns-server 172.16.4.15

R3(dhcp-config)#end

Asignar puertos a las VLANS


S1
S1(config)#interface fastEthernet 0/4
S1(config-if)#switchport access vlan 10
S1(config-if)#end

S1(config)#interface fastEthernet 0/2


S1(config-if)#switchport access vlan 12
S1(config-if)#end

S1(config)#iNterface FAStEthernet 0/3


S1(config-if)#SWitchport Access Vlan 13
S1(config-if)#end

S3
S3(config)#interface fastEthernet 0/3
S3(config-if)#switchport access vlan 30
S3(config-if)#end

S3(config)#interface fastEthernet 0/2


S3(config-if)#switchport access vlan 13
S3(config-if)#end

S2
S2(config)#interface fastEthernet 0/4
S2(config-if)#switchport access vlan 12
S2(config-if)#end

FASE 8: CONFIGURACION DE NAT, FRAME-RELAY Y PPP.

NAT.-
R2(config)#ip access-list extended vlann20
R2(config-ext-nacl)#permit ip 172.16.0.0 0.0.255.255 any
R2(config-ext-nacl)#exit

R2(config)#interface serial 0/2/0


R2(config-if)#ip access-group vlann20 in
R2(config-if)#exit
R2(config)#interface serial 0/0/1
R2(config-if)#ip access-group vlann20 in
R2(config-if)#exit

R2(config)#interface serial 0/0/0


R2(config-if)#ip access-group vlann20 in

R2(config)#interface fastEthernet 0/1


R2(config-if)#ip access-group vlann20 out
R2(config-if)#end

R2(config)#ip nat pool pool20 200.165.200.193 200.165.200.194 netmask


255.255.255.224
R2(config)#ip nat inside source list vlann20 pool pool20 overload
R2(config)#exit

Frame-relay
R2(config)#interface serial 0/0/1
R2(config-if)#encapsulation frame-relay
R2(config-if)#bandwidth 64
R2(config-if)#no sh
R2(config-if)#end

R3(config)#interface serial 0/0/1


R3(config-if)#encapsulation frame-relay
R3(config-if)#bandwidth 64
R3(config-if)#no sh
R3(config-if)#end

Configurar una conexión PPP con chap en tre los routers R2 y el ISP

Router 2:

R2(config)#username ISP password cisco


R2(config)#interface serial 0/2/0
R2(config-if)#ip address 200.165.200.193 255.255.255.224
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication chap
R2(config-if)#no shutdown
R2(config-if)#end

ISP.
ISP(config)#username R2 password cisco
ISP(config)#interface serial 0/0/0
ISP(config-if)#ip address 200.165.200.194 255.255.255.224
ISP(config-if)#encapsulation ppp
ISP(config-if)#ppp authentication chap
ISP(config-if)#no shutdown
ISP(config-if)#end
SERVIDOR CISCO

IP. 200.165.201.2
SUBNET MASK. 255.255.255.224
Gateway. 200.165.201.1

Servidor publico:

IP. 200.165.200.226
Subnet mask. 255.255.255.224
Gateway. 200.165.200.225

Linksys

Internet ip address. 172.16.3.131


Subnet. /25
Gateway. 172.16.3.254

Ip address. 172.16.4.24/25
Equipo 3.

Laura Martinez Hernandez

Nohemi Zamorano Gonzales

Eribeth Estrada vega

Eisai Garcia Balderas


Mascara de Gateway
Dispositivo Interfaz Direccion IP subred predeterminada
S0/0/0 172.16.4.17 255.255.255.252
Fa0/1.10 172.16.1.254 255.255.254.0
R1
Fa0/1.12 172.16.2.254 255.255.255.0
Fa0/1.13 172.16.3.126 255.255.255.128
S0/0/1 172.16.4.22 255.255.255.252
S0/0/0 172.16.4.18 255.255.255.252
R2 S0/2/0 200.165.200.193 255.255.255.224
Fa0/1.12 172.16.2.254 255.255.255.0
Fa0/1.20 172.16.4.14 255.255.255.240
S0/0/1 172.16.4.21 255.255.255.252
R3 Fa0/1.13 172.16.3.126 255.255.255.128
Fa0/1.30 172.16.3.254 255.255.255.128
VLAN 10 172.16.0.1 255.255.254.0 172.16.1.254
S1 VLAN 12
VLAN 13
VLAN12
S2
VLAN 20 172.16.4.1 255.255.255.240 172.16.4.14
VLAN 13
S3
VLAN 30 172.16.3.129 255.255.255.128 172.16.3.254
Servidor WEB NIC 172.16.4.14 255.255.255.240 172.16.4.1
S0/0/0 200.165.200.194 255.255.255.224
ISP Fa0/0 200.165.201.1 255.255.255.224
Fa0/1 200.165.200.225 255.255.255.224
Servidor CISCO Fa0/0 200.165.201.2 255.255.255.224 200.165.201.1
Servidor public Fa0/1 200.165.200.226 255.255.255..224 200.165.200.225

También podría gustarte